您的位置:首页 > 其它

1002. A+B for Polynomials (25)

2017-10-18 21:19 429 查看


1002. A+B for Polynomials (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2<
b17d
/sub> ... NK aNK, where
K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output
3 2 1.5 1 2.9 0 3.2


提交代

这道题目意思很简单,就是求出两个多项式相加之后后的结果,需要注意的是精度问题,不能是等于某个确切值,而是要设置一定波动范围,误差在某个范围内为真。浮点数是允许有一定的误差的在误差范围内都是真。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
double a[2009] = {0.0};
bool book[2009];
int main(){
int n,m;
int num;
double num1;
memset(book,false,sizeof(book));
memset(a,0.0,sizeof(a));
//  freopen("input.txt","r",stdin);
scanf("%d",&n);

for(int i = 0;i < n;i++){
scanf("%d%lf",&num,&num1);
a[num]+=num1;
book[num] = true;
}
scanf("%d",&m);
for(int i = 0;i < m;i++){
scanf("%d%lf",&num,&num1);
a[num]+=num1;
}
int sum = 0;
for(int i = 0;i < 2008;i++){
if(fabs(a[i])>1e-6){
sum++;
}
}

printf("%d",sum);
for(int i = 2008;i >= 0;i--){
if(fabs(a[i])>1e-6){
printf(" %d %.1lf",i,a[i]);
}
}
printf("\n");
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: