您的位置:首页 > 其它

Hdu 5750 Dertouzos 素数筛 解题报告

2017-10-18 16:10 411 查看

Problem Description

A positive proper divisor is a positive divisor of a number n, excluding n itself. For example, 1, 2, and 3 are positive proper divisors of 6, but 6 itself is not.

Peter has two positive integers n and d. He would like to know the number of integers below n whose maximum positive proper divisor is d.

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤106), indicating the number of test cases. For each test case:

The first line contains two integers n and d (2≤n,d≤109).

Output

For each test case, output an integer denoting the answer.

Sample Input

9

10 2

10 3

10 4

10 5

10 6

10 7

10 8

10 9

100 13

Sample Output

1

2

1

0

0

0

0

0

4

思路

这道题先打表打一个素数筛,然后在主函数里面特判。

代码

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<cmath>
#include<vector>
using namespace std;
const int N=100000+5;
int T,n,m,isprime
,primelist
,top=1;
void prime()
{
for (int i=2;i<=N;i++)
{
if (isprime[i]==0)
{
for (int j=2;j*i<=N;j++)
isprime[i*j]=1;
primelist[top]=i;
top++;
}
}
}
int main()
{
scanf("%d",&T);
prime();
while(T--)
{
int i;
scanf("%d%d",&m,&n);
for (i=1;i<=top;i++)
{
if (n*primelist[i]>=m) break;
if (n<primelist[i]) break;
if (n%primelist[i]==0) break;
}
if (n*primelist[i]>=m||n<primelist[i]) i--;
printf("%d\n",i);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: