您的位置:首页 > 其它

POJ - 1651 Multiplication Puzzle 区间dp

2017-10-17 22:02 197 查看

Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.

The goal is to take cards in such order as to minimize the total number of scored points.

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring

10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be

1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6

10 1 50 50 20 5

Sample Output

3650

题意:

给你一组数字,第一个和最后一个数字不可以取出去,其它任意取出去,当你要取出一个数字时,它有一个代价,这个代价就是与它相邻的两个数的乘积,求除了首位两位数字,把其他数字都取出来,它们的代价之和的最小值。

题解:

定义dp[i][j]表示将i到j合并的最小值。(最后的答案就在dp[2][n-1]中) ,然后转移的时候枚举k,表示在[i,j]这段区间中最后取k,则代价就是dp[i][k-1]+dp[k+1][j]+a[i-1]*a[k]*a[j+1]

//因为此时k这个数的两边就是i-1和j+1了,这也是为什么边界不是1和n,而是2和n-1。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int N = 100 + 10;

int n;
int a
;
int dp

;

int main(){
scanf("%d",&n);
for(int i=1;i<=n;++i) scanf("%d",&a[i]);
memset(dp,63,sizeof(dp));
for(int i=1;i<=n;++i) dp[i][i]=a[i-1]*a[i]*a[i+1],dp[i][i-1]=0;
for(int len=2;len<=n;++len){
for(int i=2;i+len-1<n;++i){
int j=i+len-1;
for(int k=i;k<=j;++k){
dp[i][j]=min(dp[i][j],dp[i][k-1]+dp[k+1][j]+a[i-1]*a[k]*a[j+1]);
}
}
}
if(n<=2) printf("0");
else printf("%d\n",dp[2][n-1]);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: