您的位置:首页 > 其它

POJ 1276:Cash Machine (多重背包)

2017-10-17 20:44 453 查看

Cash Machine

Time limit:1000 ms Memory limit:10000 kB

Problem Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes:

@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 … nN DN

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10


Sample Output

735
630
0
0


题意:

现在有一些纸币,已知每种纸币的面值和数量,现在要我们凑某个数额的钱,最多可以凑多大的值(不能超过这个数额)。

解题思路:

直接完全背包+二进制优化,现在POJ由于0x13大维护了,所以还不知道能不能AC。总之先贴在这里吧。

Code:

#include <cstdio>
#include <algorithm>
#include <iostream>
#include <list>
#include <queue>
#include <cstring>
#include <set>
#include <map>
#include <vector>
#include <cmath>
#define mem(a,b) memset(a,b,sizeof(a))

using namespace std;

const int maxN=100000;
int dp[maxN+5];

long int count,Value[maxN+5],size[maxN+5];

int main()
{
int N,cash;
while(scanf("%d",&cash)!=EOF)
{
scanf("%d",&N);
int count=0;
memset(dp,0,sizeof(dp));
for(int i=0; i<N; i++)
{
int wi,vi,ci;
scanf("%d%d",&ci,&vi);
for(int j=1; j<=ci; j<<=1)
{
Value[count]=j*vi;
size[count]=j*vi;
ci-=j;
count++;
}
if(ci>0)
{
Value[count]=ci*vi;
size[count]=ci*vi;
count++;
}
}

for(int i=0; i<count; i++)
{
for(int j=cash; j>=size[i]; j--)
{
if(dp[j] < dp[j-size[i]] + Value[i])
dp[j]=dp[j-size[i]]+Value[i];
}
}

printf("%d\n",dp[cash]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM dp 多重背包