您的位置:首页 > 编程语言 > Java开发

[PAT]1019. General Palindromic Number (20)@Java

2017-10-16 20:10 429 查看


1019. General Palindromic Number (20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N > 0 in base b >= 2, where it is written in standard notation with k+1
digits ai as the sum of (aibi) for i from 0 to k. Here, as usual, 0 <= ai < b for all i and ak is
non-zero. Then N is palindromic if and only if ai = ak-i for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any non-negative decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two non-negative numbers N and b, where 0 <= N <= 109 is the decimal number and 2 <= b <= 109 is the base. The numbers are separated
by a space.

Output Specification:

For each test case, first print in one line "Yes" if N is a palindromic number in base b, or "No" if not. Then in the next line, print N as the number in base b in the form "ak ak-1 ... a0".
Notice that there must be no extra space at the end of output.
Sample Input 1:
27 2

Sample Output 1:
Yes
1 1 0 1 1

Sample Input 2:
121 5

Sample Output 2:
No
4 4 1


package go.jacob.day1016;

import java.util.ArrayList;
import java.util.Scanner;

/**
* 1019. General Palindromic Number (20)
*
* @Jacob
*/
public class Demo1 {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int N = sc.nextInt(), base = sc.nextInt();
ArrayList<Integer> res = decimalToBase(N, base);
boolean flag = true;
int left = 0, right = res.size() - 1;
while (left < right) {
//Integer为包装类型,判断是否相等要用equals
if (!res.get(left).equals(res.get(right))) {
flag = false;
break;
}
left++;
right--;
}
if (flag)
System.out.println("Yes");
else
System.out.println("No");
System.out.print(res.get(res.size() - 1));
for (int i = res.size() - 2; i >= 0; i--) {
System.out.print(" " + res.get(i));
}
sc.close();
}

/*
* 将十进制转成base进制 要考虑N等于0的情况
*/
private static ArrayList<Integer> decimalToBase(int N, int base) {
ArrayList<Integer> res = new ArrayList<Integer>();
if (N == 0)
res.add(0);
while (N != 0) {
res.add(N % base);
N /= base;
}
return res;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: