您的位置:首页 > 编程语言 > C语言/C++

PAT甲级 1025. PAT Ranking (25)

2017-10-16 19:33 417 查看
题目:

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your
job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then
K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.
Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

思路:
1.排序时分为本地排序和总排序

2.注意排序并列的情况

代码:

#include<iostream>
#include<string>
#include<vector>
#include<algorithm>
using namespace std;
struct testee
{
string reg;
int score;
int final_rank;
int location_number;
int local_rank;
};
bool comp1(const testee &t1,const testee &t2)
{
if (t1.score != t2.score)
{
return t1.score > t2.score;
}
else
{
return t1.reg < t2.reg;
}
};

int main()
{
int N;
cin >> N;
int i,j,K;
vector<testee> list;
int n1, n2,score;
n1 = n2 = 0;
string r;
testee t;
int rank;
for (i = 1; i <= N; ++i) //每个测试地点
{
cin >> K;
n1 = n2;
for (j = 1; j <= K; ++j) //每位参与者
{
cin >> r >> score;
t.reg = r;
t.score = score;
t.location_number = i;
list.push_back(t);
++n2;
}
//每个地点成绩排序
//排序时注意并列的情况
sort(list.begin()+n1,list.begin()+n2,comp1);
rank = 0;
for (j = n1; j <n2; ++j)
{
if ((j == n1) || (list[j].score != list[j - 1].score))
rank=j-n1+1;
list[j].local_rank=rank;

}
}
sort(list.begin(),list.end(),comp1);
rank = 0;
//总排序
for (i = 0; i < n2; ++i)
{
if ((i == 0) || (list[i].score != list[i - 1].score))
rank=i+1;
list[i].final_rank = rank;

}
//输出
cout << list.size() << endl;
for (i = 0; i < list.size(); ++i)
{
cout << list[i].reg << " " << list[i].final_rank << " ";
cout << list[i].location_number << " " << list[i].local_rank << endl;
}

system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT c++