您的位置:首页 > 其它

Hdu 4336 Card Collector 概率DP+状态压缩

2017-10-16 00:08 387 查看


Card Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4704    Accepted Submission(s): 2387
Special Judge


Problem Description

In your childhood, do you crazy for collecting the beautiful cards in the snacks? They said that, for example, if you collect all the 108 people in the famous novel Water Margin, you will win an amazing award. 

As a smart boy, you notice that to win the award, you must buy much more snacks than it seems to be. To convince your friends not to waste money any more, you should find the expected number of snacks one should buy to collect a full suit of cards.

 

Input

The first line of each test case contains one integer N (1 <= N <= 20), indicating the number of different cards you need the collect. The second line contains N numbers p1, p2, ..., pN, (p1 + p2 + ... + pN <= 1), indicating the possibility of each card to
appear in a bag of snacks. 

Note there is at most one card in a bag of snacks. And it is possible that there is nothing in the bag.

 

Output

Output one number for each test case, indicating the expected number of bags to buy to collect all the N different cards.

You will get accepted if the difference between your answer and the standard answer is no more that 10^-4.

 

Sample Input

1
0.1
2
0.1 0.4

 

Sample Output

10.000
10.500

 

Source

2012 Multi-University Training Contest 4

一共n种卡片,每次抽卡片的种类是随机、等可能的。问抽到所有种类卡片的期望次数。

状态压缩,把是否抽到某种卡片的状态压缩为一个数。之后,就是按照一般的DP求期望的套路从后往前求。

#include <cstdio>
#include <iostream>
#include <string.h>
#include <string>
#include <map>
#include <queue>
#include <deque>
#include <vector>
#include <set>
#include <algorithm>
#include <math.h>
#include <cmath>
#include <stack>
#include <iomanip>
#define mem0(a) memset(a,0,sizeof(a))
#define meminf(a) memset(a,0x3f,sizeof(a))
using namespace std;
typedef long long ll;
typedef long double ld;
typedef double db;
const int maxn=25,inf=0x3f3f3f3f;
const ll llinf=0x3f3f3f3f3f3f3f3f;
const ld pi=acos(-1.0L);
db a[maxn],dp[1050005];

int main() {
int n;
while (scanf("%d",&n)!=EOF) {
int i,j,p;
db sum=0.0;
for (i=0;i<n;i++) {
scanf("%lf",&a[i]);
sum+=a[i];
}
mem0(dp);
sum=1.0-sum;
p=(1<<n)-1;
dp[p]=0;
for (i=p-1;i>=0;i--) {
db s=1,k=0;
for (j=0;j<n;j++) {
if (i&(1<<j)) {
k+=a[j];
} else {
s+=a[j]*dp[i|(1<<j)];
}
}
dp[i]=s/(1-sum-k);
}
printf("%.6lf\n",dp[0]);
}
return 0;
}

                                                                                                                    
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: