您的位置:首页 > 其它

POJ 3071 Football 概率DP入门

2017-10-15 23:37 471 查看
Football

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6123 Accepted: 3080
Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then,
the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared
the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value
on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all i ≠ j, and pii = 0.0 for all i.
The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the 
double
 data type instead
of 
float
.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least
0.01.

Sample Input
2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output
2

Hint

In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this case is:

P(2 wins) = P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4)

= p21p34p23 + p21p43p24

= 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.
The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.

Source

Stanford Local 2006

2^n个队伍两两踢淘汰赛,给你他们互相比赛的取胜概率,求哪个队伍赢的概率最大。

简单模拟即可。

#include <cstdio>
#include <iostream>
#include <string.h>
#include <string>
#include <map>
#include <queue>
#include <deque>
#include <vector>
#include <set>
#include <algorithm>
#include <math.h>
#include <cmath>
#include <stack>
#include <iomanip>
#define mem0(a) memset(a,0,sizeof(a))
#define meminf(a) memset(a,0x3f,sizeof(a))
using namespace std;
typedef long long ll;
typedef long double ld;
typedef double db;
const int maxn=155,inf=0x3f3f3f3f;
const ll llinf=0x3f3f3f3f3f3f3f3f;
const ld pi=acos(-1.0L);
db a[maxn][maxn];
db dp[maxn][10];

int main() {
int m;
scanf("%d",&m);
while (m!=-1) {
int i,j,k,l,n;
n=(1<<m);
mem0(dp);
for (i=1;i<=n;i++) {
dp[i][0]=1.0;
for (j=1;j<=n;j++) {
scanf("%lf",&a[i][j]);
}
}
for (i=1;i<=m;i++) {
int p=(1<<i);
for (j=1;j<=n;j+=p) {
for (k=j;k<j+p/2;k++) {
for (l=j+p/2;l<j+p;l++) {
dp[k][i]+=dp[l][i-1]*a[k][l];
}
dp[k][i]*=dp[k][i-1];
}
for (k=j+p/2;k<j+p;k++) {
for (l=j;l<j+p/2;l++) {
dp[k][i]+=dp[l][i-1]*a[k][l];
}
dp[k][i]*=dp[k][i-1];
}
}
/* for (j=1;j<=n;j++) {
printf("%lf ",dp[j][i]);
}
printf("\n");*/
}
int ans=1;
for (i=2;i<=n;i++) {
if (dp[i][m]>dp[ans][m]) ans=i;
}
printf("%d\n",ans);
scanf("%d",&m);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: