您的位置:首页 > 其它

Bomb(HDU 3555 数位DP)

2017-10-15 20:34 288 查看

Bomb

[align=center]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 20230    Accepted Submission(s): 7565

[/align]

[align=left]Problem Description[/align]
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the
power of the blast would add one point.

Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

 

[align=left]Input[/align]
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.

 

[align=left]Output[/align]
For each test case, output an integer indicating the final points of the power.
 

[align=left]Sample Input[/align]

3
1
50
500

 

[align=left]Sample Output[/align]

0
1
15

HintFrom 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499",
so the answer is 15.

 
//题意:给一个数字n,问1-n里有几个数包含49.

//思路:数位DP:

dp[i][0]代表长度为 i 并且不含有49的数字的个数;
dp[i][1]代表长度为 i 并且不含有49,但是最高位是9的数字的个数;

dp[i][2]代表长度为 i 并且含有49的数字的个数。

状态转移方程:

dp[i][0] = dp[i-1][0] * bit[i] - dp[i-1][1];

dp[i][1]=dp[i-1][1];

dp[i][2]=dp[i-1][2]*bit[i]+dp[i-1][1];

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>

using namespace std;

typedef long long ll;

ll n;
int bit[25];
ll dp[25][5];

int main()
{
int T;
scanf("%d",&T);
memset(dp,0,sizeof(dp));
dp[0][0]=1;
for(int i=1;i<21;i++)
{
dp[i][0]=dp[i-1][0]*10-dp[i-1][1];
dp[i][1]=dp[i-1][0];
dp[i][2]=dp[i-1][2]*10+dp[i-1][1];
}
while(T--)
{
scanf("%I64d",&n);
memset(bit,0,sizeof(bit));
ll x=n+1;
int len=0;
while(x)
{
bit[++len]=x%10;
x=x/10;
}
ll ans=0;
bool flag=false;
int last=0;
for(int i=len;i>=1;i--)
{
ans+=(dp[i-1][2]*bit[i]);
if(flag)
ans+=dp[i-1][0]*bit[i];
if(!flag&&bit[i]>4)
ans+=dp[i-1][1];
if(last==4&&bit[i]==9)
flag=true;
last=bit[i];
}
printf("%I64d\n",ans);
}
return 0;
}


b8ec
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: