您的位置:首页 > 移动开发

HDU5119 Happy Matt Friends (dp && 0-1背包)

2017-10-15 10:15 218 查看


Happy Matt Friends

Time Limit: 6000/6000 MS (Java/Others)    Memory Limit: 510000/510000 K (Java/Others)

Total Submission(s): 4602    Accepted Submission(s): 1746


Problem Description

Matt has N friends. They are playing a game together.

Each of Matt’s friends has a magic number. In the game, Matt selects some (could be zero) of his friends. If the xor (exclusive-or) sum of the selected friends’magic numbers is no less than M , Matt wins.

Matt wants to know the number of ways to win.

 

Input

The first line contains only one integer T , which indicates the number of test cases.

For each test case, the first line contains two integers N, M (1 ≤ N ≤ 40, 0 ≤ M ≤ 106).

In the second line, there are N integers ki (0 ≤ ki ≤ 106), indicating the i-th friend’s magic number.

 

Output

For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y indicates the number of ways where Matt can win.

 

Sample Input

2
3 2
1 2 3
3 3
1 2 3

 

Sample Output

Case #1: 4
Case #2: 2

HintIn the first sample, Matt can win by selecting:
friend with number 1 and friend with number 2. The xor sum is 3.
friend with number 1 and friend with number 3. The xor sum is 2.
friend with number 2. The xor sum is 2.
friend with number 3. The xor sum is 3. Hence, the answer is 4.

 

Source

2014ACM/ICPC亚洲区北京站-重现赛(感谢北师和上交)

思路:对于第i个元素来说有两种选择,选或者不选,要求的就是异或和大于等于m的异或方法数,然后该问题就可以转化成为0-1背包问题,=>有N个物品,每个物品有方或者不放两种选择,求放进背包中物品的价值>=m的方法数。

牵扯到位运算是尽量使用左移右移确定边界值

#include <cstdio>
#include <cstring>
#include <algorithm>
#define LL long long
using namespace std;

const int maxn = 1 << 20;//1<<20 = 1024*1024 > 1e6 所以可以定为上界
int t,N,M,cas = 0;
int a[45],dp[2][maxn];

int main(){
scanf("%d",&t);
while(t --){
scanf("%d%d",&N,&M);
memset(dp,0,sizeof(dp));
for(int i = 1; i <= N; i ++) scanf("%d",&a[i]);
dp[0][0] = 1;
for(int i = 1; i <= N; i ++){
for(int j = 0; j < maxn; j ++){
dp[i % 2][j] = dp[(i-1) % 2][j] + dp[(i-1) % 2][j ^ a[i]];
}
}
LL ans = 0;
for(int i = M; i < maxn; i ++) ans += dp[N % 2][i];
printf("Case #%d: %lld\n",++ cas, ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: