您的位置:首页 > 其它

hdu 1536 S-Nim(SG函数)

2017-10-14 12:14 393 查看

S-Nim

Problem Description

Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:

The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.

The players take turns chosing a heap and removing a positive number of beads from it.

The first player not able to make a move, loses.

Arthur and Caroll really enjoyed playing this simple game until they recently learned an easy way to always be able to find the best move:

Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).

If the xor-sum is 0, too bad, you will lose.

Otherwise, move such that the xor-sum becomes 0. This is always possible.

It is quite easy to convince oneself that this works. Consider these facts:

The player that takes the last bead wins.

After the winning player’s last move the xor-sum will be 0.

The xor-sum will change after every move.

Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win.

Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove a number of beads in some predefined set S, e.g. if we have S =(2, 5) each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it?

your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position. This means, as expected, that a position with no legal moves is a losing position.

Input

Input consists of a number of test cases. For each test case: The first line contains a number k (0 < k ≤ 100 describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0 < m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps. The last test case is followed by a 0 on a line of its own.

Output

For each position: If the described position is a winning position print a ‘W’.If the described position is a losing position print an ‘L’. Print a newline after each test case.

Sample Input

2 2 5

3

2 5 12

3 2 4 7

4 2 3 7 12

5 1 2 3 4 5

3

2 5 12

3 2 4 7

4 2 3 7 12

0

Sample Output

LWW

WWL

思路:最基础的SG函数

注意:给出的S集合并不一定是单调递增的

SG函数学习博客:Strangedbly

代码:<
4000
/p>

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

const int maxn=1e4+10;
int sg[maxn],f[110],a[110][110];
bool vis[maxn];
int k;

void Get_SG(int n)
{
memset(sg,0,sizeof(sg));
for(int i=1; i<=n; ++i)
{
memset(vis,false,sizeof(vis));
for(int j=1; j<=k&&f[j]<=i; ++j)
vis[sg[i-f[j]]]=true;
for(int j=0;; ++j)
if(!vis[j])
{
sg[i]=j;
break;
}
}
}

int main()
{
while(scanf("%d",&k),k)
{
for(int i=1; i<=k; ++i)
scanf("%d",&f[i]);
sort(f+1,f+1+k);
int m,n,maxx=0;
scanf("%d",&m);
for(int i=1; i<=m; ++i)
{
scanf("%d",&a[i][0]);
for(int j=1; j<=a[i][0]; ++j)
scanf("%d",&a[i][j]),maxx=max(maxx,a[i][j]);
}
Get_SG(maxx);
for(int i=1; i<=m; ++i)
{
int ans=0;
for(int j=1; j<=a[i][0]; ++j)
ans^=sg[a[i][j]];
if(ans)
printf("W");
else
printf("L");
}
puts("");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: