您的位置:首页 > 其它

Largest Rectangle in a Histogram POJ - 2559 单调栈

2017-10-14 11:22 369 查看
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists
of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:



Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned
at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input
The input contains several test cases. Each test case describes a histogram and starts with an integer
n, denoting the number of rectangles it is composed of. You may assume that
1<=n<=100000. Then follow n integers h1,...,hn, where
0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is
1. A zero follows the input for the last test case.
Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output
8
4000

Hint
Huge input, scanf is recommended.

#include<cstdio>
#include<cstring>
#include<stack>
#include<algorithm>
#include<queue>
using namespace std;
const int M=100010;
int n;
int h[M],l[M],r[M],st[M];
int main()
{
while(scanf("%d",&n),n)
{
memset(l,0,sizeof(l));
memset(r,0,sizeof(r));
memset(st,0,sizeof(st));
for(int i=0;i<n;i++)
scanf("%d",&h[i]);
int t=0;
for(int i=0;i<n;i++)
{
while(t>0&&h[st[t-1]]>=h[i])
t--;
l[i]= t==0?0:(st[t-1]+1);
st[t++]=i;
}
t=0;
for(int i=n-1;i>=0;i--)
{
while(t>0&&h[st[t-1]]>=h[i])
t--;
r[i]= t==0?n:(st[t-1]);
st[t++]=i;
}
long long ans=0;
for(int i=0;i<n;i++)
{
ans=max(ans,(long long)h[i]*(r[i]-l[i]));
}
printf("%lld\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: