您的位置:首页 > 运维架构

C Looooops(扩展欧几里得)

2017-10-13 21:14 330 查看
H - C Looooops
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d
& %I64u
Submit Status Practice POJ
2115

Appoint description: 

Description

A Compiler Mystery: We are given a C-language style for loop of type 
for (variable = A; variable != B; variable += C)

statemen
4000
t;


I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming
that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2 k) modulo 2 k. 

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C
< 2 k) are the parameters of the loop. 

The input is finished by a line containing four zeros. 

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate. 

Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0


Sample Output

0
2
32766
FOREVER


 

题意:for(i=A;i!=B;i+=C){i%(2^k)};问你循环执行几次?

 

思路:先假设等式成立:(A+x*C)%(2^k)=B

 

          变形(2^k)*y+B=A+C*x        ==>        C*x+(-(2^k)*y)=B-A;

 

                                                         ax+by=c

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
typedef long long ll;
ll ex_gcd(ll a,ll b,ll &x,ll &y){
if(b==0){
x = 1;
y = 0;
return a;
}
ll r = ex_gcd(b,a%b,y,x);
y -= x*(a/b);
return r;
}
ll a,b,c,x,y;
ll A,B,C,k;
int main(){
while(~scanf("%lld%lld%lld%lld",&A,&B,&C,&k)&&(A+B+C+k)){
a = C;
b = (ll)1<<k;//一定要把这里的1转成ll类型,在这里错了无数次。。
c = B-A;
if(c==0){
printf("0\n");
continue;
}//特殊情况判断
ll gcd = ex_gcd(a,b,x,y);
if(c%gcd!=0){
printf("FOREVER\n");
continue;
}
x *= c/gcd;
b /= gcd;
if(b<0)b=-b;
x = x%b;
if(x<0)x += b;
printf("%lld\n",x);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: