您的位置:首页 > 其它

POJ 1144 Tarjan 割点 解题报告

2017-10-13 14:40 405 查看
Network

Description

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N . No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is

possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure

occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.

Input

The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated

by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0;

Output

The output contains for each block except the last in the input file one line containing the number of critical places.

Sample Input

5

5 1 2 3 4

0

6

2 1 3

5 4 6 2

0

0

Sample Output

1

2

【解题报告】

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define N 110

int n,cnt,head
;
struct Edge{int to,nxt;}e[N*N];
int dfn
,low
,vis
,cut
;
int indexx,root,ans;

void init()
{
cnt=-1;indexx=root=ans=0;
memset(head,-1,sizeof(head));
memset(dfn,-1,sizeof(dfn));
memset(low,-1,sizeof(low));
memset(vis,0,sizeof(vis));
memset(cut,0,sizeof(cut));
}
void adde(int u,int v)
{
e[++cnt].to=v;e[cnt].nxt=head[u];head[u]=cnt;
e[++cnt].to=u;e[cnt].nxt=head[v];head[v]=cnt;
}
void tarjan(int u)
{
dfn[u]=low[u]=++indexx;
vis[u]=1;
for(int i=head[u];~i;i=e[i].nxt)
{
int v=e[i].to;
if(!vis[v])
{
tarjan(v);
low[u]=min(low[u],low[v]);
if(low[v]>=dfn[u]&&u!=1) cut[u]=1;
else if(u==1) root++;
}
else low[u]=min(low[u],dfn[v]);
}
}
int main()
{
while(scanf("%d",&n)&&n)
{
init();int u,v;
while(scanf("%d",&u)&&u)
{
while(getchar()!='\n')
{
scanf("%d",&v);
adde(u,v);
}
}
for(int i=1;i<=n;++i)
if(dfn[i]==-1) tarjan(i);
if(root>1) ans++;
for(int i=2;i<=n;++i) if(cut[i]) ans++;
printf("%d\n",ans);
}
return 0;
}


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define N 110

int n,cnt=-1,head
;
struct Edge{int to,nxt;}e[N*N];
int idc,dfn
,low
,vis
,cut
;

void init()
{
cnt=-1;idc=0;
memset(head,-1,sizeof(head));
memset(dfn,0,sizeof(dfn));
memset(low,0,sizeof(low));
memset(vis,0,sizeof(vis));
memset(cut,0,sizeof(cut));
}
void adde(int u,int v)
{
e[++cnt].to=v;e[cnt].nxt=head[u];head[u]=cnt;
e[++cnt].to=u;e[cnt].nxt=head[v];head[v]=cnt;
}
void Tarjan(int u)
{
dfn[u]=low[u]=++idc;vis[u]=1;
for(int i=head[u];~i;i=e[i].nxt)
{
int v=e[i].to;
if(!vis[v])
{
Tarjan(v);
low[u]=min(low[u],low[v]);
if(low[v]>=dfn[u]) cut[u]++;
}
else low[u]=min(low[u],dfn[v]);
}
}
int main()
{
while(~scanf("%d",&n)&&n)
{
init();
int u,v;
while(scanf("%d",&u)&&u)
{
while(getchar()!='\n')
{
scanf("%d",&v);
adde(u,v);
}
}
for(int i=1;i<=n;++i) if(!vis[i]) Tarjan(i);
int ans=0;
cut[1]--;
for(int i=1;i<=n;++i) printf("%d ",dfn[i]);puts("");
for(int i=1;i<=n;++i) printf("%d ",low[i]);puts("");
for(int i=1;i<=n;++i)
{
printf("%d ",cut[i]);
if(cut[i]>0) ans+=1;
}
puts("");
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: