您的位置:首页 > 其它

HDU 1219 AC Me

2017-10-13 14:21 344 查看
http://acm.hdu.edu.cn/showproblem.php?pid=1219

 

AC Me


Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K
(Java/Others)

Total Submission(s): 6651 Accepted Submission(s):
2982


[align=left]Problem Description[/align]
Ignatius is doing his homework now. The
teacher gives him some articles and asks him to tell how many times
each letter appears.

It's really easy, isn't it? So come on and AC ME.

 

[align=left]Input[/align]
Each article consists of just one line,
and all the letters are in lowercase. You just have to count the
number of each letter, so do not pay attention to other characters.
The length of article is at most 100000. Process to the end of
file.

Note: the problem has multi-cases, and you may use
"while(gets(buf)){...}" to process to the end of file.

 

[align=left]Output[/align]
For each article, you have to tell how
many times each letter appears. The output format is like
"X:N".

Output a blank line after each test case. More details in sample
output.

 

[align=left]Sample Input[/align]

hello, this
is my first acm contest! work hard for hdu acm.

 

[align=left]Sample Output[/align]

a:1 b:0 c:2
d:0 e:2 f:1 g:0 h:2 i:3 j:0 k:0 l:2 m:2 n:1 o:2 p:0 q:0 r:1 s:4 t:4
u:0 v:0 w:0 x:0 y:1 z:0 a:2 b:0 c:1 d:2 e:0 f:1 g:0 h:2 i:0 j:0 k:1
l:0 m:1 n:0 o:2 p:0 q:0 r:3 s:0 t:0 u:1 v:0 w:1 x:0 y:0 z:0

 

[align=left]Author[/align]
Ignatius.L

 

[align=left]Source[/align]

杭州电子科技大学第三届程序设计大赛

 

[align=left]Recommend[/align]
Ignatius.L
 
分析:简单题。。
代码如下:

#include<stdio.h>

#include<string.h>

char x[100001];

int ans[26];

int count=0;

int main()

{

 int len,i;

   
while(gets(x))

    {

   
// if(count!=0) printf("\n");

      
memset(ans,0,sizeof(ans));

      
len=strlen(x);

   
for(i=0;i<len;i++)

       
 {

       
  if(x[i]>='a'
&& x[i]<='z')

       
    
ans[(int)x[i]-'a']++;

       
 }

   
for(i=0;i<26;i++)

      
printf("%c:%d\n",i+'a',ans[i]);

 //  count++;

   
printf("\n");   
 

    }

 return 0; 

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: