您的位置:首页 > 编程语言 > C语言/C++

PAT甲级 1023. Have Fun with Numbers (20)

2017-10-13 13:13 489 查看
题目:

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different
permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.
Sample Input:
1234567899

Sample Output:
Yes
2469135798

思路:
这题很简单,读取字符串,做乘法并统计数字个数。注意一下进位就好了。

代码:

这程序写得有些繁琐,但还是通过了。

#include<iostream>
#include<string>
#include<vector>
using namespace std;

int main()
{
int digit[10] = { 0 };
int digit2[10] = { 0 };
//input
string s;
cin >> s;
vector<int> d_s;
int i;
int d1,d2;
int tmp = 0;
for (i = s.size() - 1; i >= 0; --i)
{
d1 = s[i] - '0';
digit[d1]++;
d2 = (d1 * 2+tmp) % 10;
tmp = (d1 * 2 + tmp) / 10;
d_s.push_back(d2);
digit2[d2]++;
}
if (tmp != 0)
{
d_s.push_back(tmp);
digit2[tmp]++;
}
int flag = 0;
for (i = 0; i <= 9; ++i)
{
if (digit[i] != digit2[i])
flag++;
if (flag > 0)
break;
}
if (flag > 0)
cout << "No" << endl;
else
cout << "Yes" << endl;
for (i = d_s.size() - 1; i >= 0; --i)
cout << d_s[i];
cout << endl;
system("pause");
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT c++