您的位置:首页 > 其它

1025. 反转链表 (25)

2017-10-12 11:38 330 查看
给定一个常数K以及一个单链表L,请编写程序将L中每K个结点反转。例如:给定L为1→2→3→4→5→6,K为3,则输出应该为3→2→1→6→5→4;如果K为4,则输出应该为4→3→2→1→5→6,即最后不到K个元素不反转。输入格式:每个输入包含1个测试用例。每个测试用例第1行给出第1个结点的地址、结点总个数正整数N(<= 105)、以及正整数K(<=N),即要求反转的子链结点的个数。结点的地址是5位非负整数,NULL地址用-1表示。接下来有N行,每行格式为:Address Data Next其中Address是结点地址,Data是该结点保存的整数数据,Next是下一结点的地址。输出格式:对每个测试用例,顺序输出反转后的链表,其上每个结点占一行,格式与输入相同。输入样例:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
输出样例:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1#include <iostream>
#include <stdlib.h>
#include <string>
#include <vector>
#include <iomanip>
using namespace std;
typedef struct node{
int address;
int data;
int next;
}Node;
int main()
{
int head[3];
int tempAddress;
int i=0;
for(i=0;i<3;i++)
cin>>head[i];
tempAddress=head[0];
const int row = head[1];
int group=head[2];
Node input[row];
Node output[row];
Node result[row];
for(i=0;i<row;i++){
cin>>input[i].address;
cin>>input[i].data;
cin>>input[i].next;
}
for(i=0;i<row;i++){
for(int j=0;j<row;j++){
if(input[j].address==tempAddress){
output[i]=input[j];
tempAddress=output[i].next;
break;
}
}
}
int k=0;
for(i=0;i<=(row/group);i++){
if(i!=(row/group)){
for(int j=(group-1);j>=0;j--){
result[k]=output[i*group+j];
if(j!=0)
result[k].next=output[i*group+j-1].address;
else{
if(k!=(row-1))
result[k].next=output[(i+1)*group].address;
else
result[k].next=-1;
}
k++;
}
}else{
while(k<row){
result[k]=output[k];
k++;
}
}
}
for(i=0;i<row;i++){
cout<<setw(5)<<setfill('0')<<result[i].address<<" ";
cout<<result[i].data<<" ";
if(i!=(row-1))
cout<<setw(5)<<setfill('0')<<result[i].next<<endl;
else{
cout.setf(ios::left);
cout<<setw(5)<<setfill(' ')<<result[i].next<<endl;
}
}
system("pause");
return 0;
}
有样例不能通过!!!
                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: