您的位置:首页 > Web前端

洛谷 P1118 [USACO06FEB]数字三角形Backward Digit Su…

2017-10-12 11:08 295 查看
题目描述

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this:

3   1   2   4
4   3   6
7   9
16


Behind FJ’s back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ’s mental arithmetic capabilities.

Write a program to help FJ play the game and keep up with the cows.

有这么一个游戏:

写出一个1~N的排列a[i],然后每次将相邻两个数相加,构成新的序列,再对新序列进行这样的操作,显然每次构成的序列都比上一次的序列长度少1,直到只剩下一个数字位置。下面是一个例子:

3 1 2 4

4 3 6

7 9

16

最后得到16这样一个数字。

现在想要倒着玩这样一个游戏,如果知道N,知道最后得到的数字的大小sum,请你求出最初序列a[i],为1~N的一个排列。若答案有多种可能,则输出字典序最小的那一个。

[color=red]管理员注:本题描述有误,这里字典序指的是1,2,3,4,5,6,7,8,9,10,11,12

而不是1,10,11,12,2,3,4,5,6,7,8,9[/color]

输入输出格式

输入格式:

两个正整数n,sum。

输出格式:

输出包括1行,为字典序最小的那个答案。

当无解的时候,请什么也不输出。(好奇葩啊)、

输入输出样例

输入样例#1:

4 16

输出样例#1:

3 1 2 4

说明

对于40%的数据,n≤7;

对于80%的数据,n≤10;

对于100%的数据,n≤12,sum≤12345。

/*
设 所求的一个序列是 a,b,c,d.,,,,,,
如果n为4,那么sum是1a+3b+3c+1d
如果n为5,那么sum是1a+4b+6c+4d+1e
如果n为6,那么sum是1a+5b+10c+10d+5e+1f
系数是杨辉三角
预处理一个杨辉三角  搜索就好
*/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;
int n, Sum ,C[20][20],a[14];
bool used[14];

void DFS(int step,int s){
if(s > Sum) return;
if(step == n + 1){
if(s == Sum){
for(int i=1; i<=n; ++i) printf("%d ",a[i]);
exit(0);
}
return ;
}
for(int i=1; i<=n; ++i)
if(!used[i]){
a[step] = i;
s += C
[step] * i;
used[i] = true;
DFS(step + 1,s) ;
used[i] = false;
s -= C
[step] * i;
}
}

int main(int argc,char *argv[]){
scanf("%d%d", &n ,&Sum);
C[1][1] = 1;
for(int i=2; i<=n; ++i)
for(int j=1; j<=i; ++j)
C[i][j] = C[i - 1][j] + C[i - 1][j - 1];

DFS(1,0);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  组合数 搜索