您的位置:首页 > 其它

Binary String Matching

2017-10-11 14:42 253 查看
Binary String Matching

时间限制:3000 ms | 内存限制:65535 KB

难度:3

描述

Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit

输入

The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.

输出

For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.

样例输入

3

11

1001110110

101

110010010010001

1010

110100010101011

样例输出

3

0

3

分析:

直接暴力

代码:

#include <iostream>
#include <stdio.h>
#include <string.h>

int main(int argc, char** argv) {
int t;
scanf("%d",&t);

while(t--){

getchar();
char sub[11];
char str[1011];
scanf("%s",sub);
getchar();
scanf("%s",str);

int length1 = strlen(sub);
int length2 = strlen(str);

int count = 0;
for(int i=0;i<length2;i++){
for(int j=0;j<length1;j++){
if(str[i+j] == sub[j]){
if(j == length1-1){
count++;
}
continue;
}else{
break;
}
}
}

printf("%d\n",count);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: