您的位置:首页 > 其它

poj 3636

2017-10-10 14:56 519 查看
Nested Dolls
http://poj.org/problem?id=3636

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 8630Accepted: 2367
Description

Dilworth is the world's most prominent collector of Russian nested dolls: he literally has thousands of them! You know, the wooden hollow dolls of different sizes of which the smallest doll is contained in the second smallest, and this doll is in turn contained in the next one and so forth. One day he wonders if there is another way of nesting them so he will end up with fewer nested dolls? After all, that would make his collection even more magnificent! He unpacks each nested doll and measures the width and height of each contained doll. A doll with width w1 and height h1 will fit in another doll of width w2 and height h= if and only if w1 < w2 and h1 < h2. Can you help him calculate the smallest number of nested dolls possible to assemble from his massive list of measurements?

Input

On the first line of input is a single positive integer 1 ≤ t ≤ 20 specifying the number of test cases to follow. Each test case begins with a positive integer 1 ≤ m ≤ 20000 on a line of itself telling the number of dolls in the test case. Next follow 2m positive integers w1, h1,w2, h2, ... ,wm, hm, where wi is the width and hi is the height of doll number i. 1 ≤ wi, hi ≤ 10000 for all i.

Output

For each test case there should be one line of output containing the minimum number of nested dolls possible.

Sample Input

4
3
20 30 40 50 30 40
4
20 30 10 10 30 20 40 50
3
10 30 20 20 30 10
4
10 10 20 30 40 50 39 51

Sample Output

1
2
3
2

Source

Nordic 2007



不是很懂这个排序

上题是最长严格递减子序列,这题是最长不上升子序列

#include<cstdio>
#include<iostream>
#include<algorithm>

#define N 20001

using namespace std;

struct node
{
int a,b;
}e
;

int s,f
;

bool cmp(node p,node q)
{
if(p.a!=q.a) return p.a<q.a;
return p.b>q.b;
}

int find(int w)
{
int l=1,r=s,mid,tmp=-1;
while(l<=r)
{
mid=l+r>>1;
if(f[mid]<w) tmp=mid,r=mid-1;
else l=mid+1;
}
return tmp;
}

int main()
{
int T,n,pos;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
for(int i=1;i<=n;i++) scanf("%d%d",&e[i].a,&e[i].b);
sort(e+1,e+n+1,cmp);
f[s=0]=2e9;
for(int i=1;i<=n;i++)
if(e[i].b<=f[s]) f[++s]=e[i].b;
else
{
pos=find(e[i].b);
if(pos>0) f[pos]=e[i].b;
}
printf("%d\n",s);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: