您的位置:首页 > 其它

PAT 甲级 1103. Integer Factorization (30)

2017-10-09 15:16 337 查看
The K-P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K-P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (<=400), K (<=N) and P (1<P<=7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n1^P + ... nK^P

where ni (i=1, ... K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122 + 42 + 22 + 22 +
12, or 112 + 62 + 22 + 22 + 22, or more. You must output the
one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a1, a2, ... aK } is said to be larger than
{ b1, b2, ... bK } if there exists 1<=L<=K such that ai=bi for i<L and aL>bL

If there is no solution, simple output "Impossible".
Sample Input 1:
169 5 2

Sample Output 1:
169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2

Sample Input 2:
169 167 3

Sample Output 2:
Impossible

#include <algorithm>
#include <cstdio>
#include <iostream>
#include <vector>
#include <queue>
using namespace std;
vector<int> v, ans, tempAns;
int n, k, p, maxFacSum = -1;
void init() {
int temp = 0, index = 1;
while (temp <= n) {
v.push_back(temp);
temp = pow(index, p);
index++;
}
}

void dfs(int index, int tempSum, int tempK, int facSum) {
if (tempSum == n&&tempK == k) {
if (facSum > maxFacSum) {
ans = tempAns;
maxFacSum = facSum;
}
return;
}
if (tempSum > n || tempK > k) return;
if (index >= 1) {
tempAns.push_back(index);
dfs(index, tempSum + v[index], tempK + 1, facSum + index);
tempAns.pop_back();
dfs(index - 1, tempSum, tempK, facSum);
}
}
int main() {
scanf("%d%d%d", &n, &k, &p);
init();
dfs(v.size() - 1, 0, 0, 0);
if (maxFacSum == -1) {
printf("Impossible");
return 0;
}
printf("%d = ", n);
for (int i = 0; i < ans.size(); i++) {
if (i != 0) printf(" + ");
printf("%d^%d", ans[i], p);
}
return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: