您的位置:首页 > 其它

POJ 2318 TOYS (叉积)

2017-10-08 17:45 405 查看
Description

Calculate the number of toys that land in each bin of a partitioned toy box.

Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.

John’s parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.



For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0

3 1

4 3

6 8

10 10

15 30

1 5

2 1

2 8

5 5

40 10

7 9

4 10 0 10 100 0

20 20

40 40

60 60

80 80

5 10

15 10

25 10

35 10

45 10

55 10

65 10

75 10

85 10

95 10

0

Sample Output

0: 2

1: 1

2: 1

3: 1

4: 0

5: 1

0: 2

1: 2

2: 2

3: 2

4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are “in” the box.

大致题意:给你n条线段,将一个矩形柜子分成了n+1个区域,然后告诉你m个点的坐标,问你这个n+1个区域里的点的个数分别是多少,输出。

思路:用叉积来判断一个点是在线段的左边还是右边,然后还可以发现答案具有单调性,所以用二分来做。

代码如下

#include<iostream>
#include<set>
#include<vector>
#include<algorithm>
#include<cstring>
#include<cstdio>
using namespace std;
typedef long long ll;
const int N=6000;
struct Point {
int x,y;
Point() {}
Point(int _x,int _y) {
x=_x;
y=_y;
}
Point operator-(const Point &b) const {
return Point(x-b.x,y-b.y);
}
int operator *(const Point &b)const {
return x*b.x + y*b.y;
}
int operator ^(const Point &b)const {
return x*b.y - y*b.x;
}
};
struct Line {
Point a,b;
Line() {}
Line(Point _a,Point _b) {
a=_a;
b=_b;
}
};
int Xmult(Point p0,Point p1,Point p2) { //叉积
return (p1-p0)^(p2-p0);
}
Line line
;
int ans
;
int main()
{
int n,m,x1,y1,x2,y2;
int f=0;
while(1)
{
scanf("%d",&n);
if(!n)  break;
if(!f) f=1;
else printf("\n");
scanf("%d%d%d%d%d",&m,&x1,&y1,&x2,&y2);
int Ui,Li;
for(int i=0;i<n;i++)
{
scanf("%d%d",&Ui,&Li);
line[i]=Line(Point(Ui,y1),Point(Li,y2));
}
line
=Line(Point(x2,y1),Point(x2,y2));
Point P;
memset(ans,0,sizeof(ans));
int x,y;
while(m--)
{
scanf("%d%d",&x,&y);
P=Point(x,y);
int l=0,r=n;
int now;
while(l<=r)
{
int mid=(l+r)/2;
if(Xmult(P,line[mid].a,line[mid].b)<0)//点在线段的左边
{
now=mid;
r=mid-1;
}
else l=mid+1;
}
ans[now]++;
}
for(int i=0;i<=n;i++)
printf("%d: %d\n",i,ans[i]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: