您的位置:首页 > 其它

Is Derek lying? HDU - 6045 思维

2017-10-08 17:39 363 查看
Derek
and
Alfia
are good friends.Derek
is Chinese,and
Alfia
is Austrian.This summer holiday,they both participate in the summer camp of Borussia Dortmund.During the summer camp,there will be fan tests at intervals.The test consists of

N
choice questions and each question is followed by three choices marked “A”
“B”
and “C”.Each
question has only one correct answer and each question is worth
1
point.It means that if your answer for this question is right,you can get
1
point.The total score of a person is the sum of marks for all questions.When the test is over,the computer will tell

Derek
the total score of him and
Alfia.Then

Alfia
will ask
Derek
the total score of her and he will tell her: “My total score is
X,your
total score is
Y.”But

Derek
is naughty,sometimes he may lie to her. Here give you the answer that
Derek
and
Alfia
made,you should judge whether
Derek
is lying.If there exists a set of standard answer satisfy the total score that
Derek

said,you can consider he is not lying,otherwise he is lying.

Input The first line consists of an integer
T,represents
the number of test cases.

For each test case,there will be three lines.

The first line consists of three integers
N,X,Y,the
meaning is mentioned above.

The second line consists of
N
characters,each character is “A”
“B”
or “C”,which
represents the answer of
Derek
for each question.

The third line consists of
N
characters,the same form as the second line,which represents the answer of
Alfia
for each question.

Data Range:1≤N≤80000,0≤X,Y≤N,∑Ti=1N≤300000
Output For each test case,the output will be only a line.

Please print “Lying”
if you can make sure that
Derek
is lying,otherwise please print “Not lying”. Sample Input
2
3 1 3
AAA
ABC
5 5 0
ABCBC
ACBCB

Sample Output
Not lying
Lying


 #include<cmath>
#include<cstring>
#include<cstdio>
using namespace std;
const int M=80010;
char s1[M],s2[M];
int t,n,a,b;
int main()
{
scanf("%d",&t);
while(t--)
{
scanf("%d%d%d",&n,&a,&b);
int c=0;
scanf("%s",s1);
scanf("%s",s2);
for(int i=0;i<n;i++)
if(s1[i]==s2[i])
c++;
if(a+b<=n+c&&abs(a-b)<=n-c)
printf("Not lying\n");
else
printf("Lying\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: