您的位置:首页 > 其它

Spell checker (poj 1035 字符串)

2017-10-07 22:11 375 查看
[align=center]Spell checker[/align]

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 26010Accepted: 9534
Description
You, as a member of a development team for a new spell checking program, are to write a module that will check the
correctness(正确性) of given words using a known dictionary of all correct words in all their forms.

If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations:

?deleting of one letter from the word;

?replacing of one letter in the word with an arbitrary letter;

?inserting of one arbitrary letter into the word.

Your task is to write the program that will find all possible replacements from the dictionary for every given word.

Input
The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different.
There will be at most 10000 words in the dictionary.

The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked.

All words in the input file (words from the dictionary and words to be checked) consist only of small
alphabetic(字母的) characters and each one contains 15 characters at most.

Output
Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write
the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their
appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.
Sample Input
i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#

Sample Output
me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me

Source
Northeastern Europe 1998

#include <cstdio>
#include <cstring>
#include <string>
#include <iostream>
#include <cstdlib>

using namespace std;

string diction[10005], str1[10005];

int main()
{
int dic = 0, need = 0;
while (cin >> diction[dic]) {
if (diction[dic] == "#") break;
dic++;
}
while (cin >> str1[need]) {
if (str1[need] == "#") break;
need++;
}
for (int i = 0; i<need; i++) {
int flog = 0;
for (int j = 0; j<dic; j++) {
if (str1[i] == diction[j]) {//如果相同
cout << str1[i] << " is correct" << endl;
flog = 1;
break;
}
}
if (flog == 1) continue;
int len = str1[i].size();
cout << str1[i] << ":";
for (int j = 0; j<dic; j++) {
int Lengthofword = diction[j].size();
if (Lengthofword == len || Lengthofword == len + 1 || Lengthofword == len - 1) {//长度相差一及以内
int ans = 0;
if (len>Lengthofword) { //用较短的匹配较长的
for (int m = 0, d = 0; m<len; m++) {
if (str1[i][m] == diction[j][d]) {
ans++;
d++;
}
}
}
else if (len<Lengthofword) {
for (int m = 0, d = 0; m<Lengthofword; m++) {
if (diction[j][m] == str1[i][d]) {
ans++;
d++;
}
}
}
else if (len == Lengthofword) {//长度相等但不相同
for (int m = 0, d = 0; m<Lengthofword; m++, d++)
if (diction[j][m] == str1[i][d]) ans++;
}
if (len >= Lengthofword&&ans == len - 1) cout << " " << diction[j];//可以替换或删除
if (len<Lengthofword&&ans == len) cout << " " << diction[j];//可以添加
}
}
cout << endl;
}
return 0;
}转载地址:http://www.cnblogs.com/Tree-dream/p/5493771.html

参考地址:優YoU http://user.qzone.qq.com/289065406/blog/1309051410
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  字符串