您的位置:首页 > 其它

(POJ 1847)Tram 简单最短路 spfa

2017-10-07 13:38 525 查看
Tram

Time Limit: 1000MS Memory Limit: 30000K

Total Submissions: 16731 Accepted: 6210

Description

Tram network in Zagreb consists of a number of intersections and rails connecting some of them. In every intersection there is a switch pointing to the one of the rails going out of the intersection. When the tram enters the intersection it can leave only in the direction the switch is pointing. If the driver wants to go some other way, he/she has to manually change the switch.

When a driver has do drive from intersection A to the intersection B he/she tries to choose the route that will minimize the number of times he/she will have to change the switches manually.

Write a program that will calculate the minimal number of switch changes necessary to travel from intersection A to intersection B.

Input

The first line of the input contains integers N, A and B, separated by a single blank character, 2 <= N <= 100, 1 <= A, B <= N, N is the number of intersections in the network, and intersections are numbered from 1 to N.

Each of the following N lines contain a sequence of integers separated by a single blank character. First number in the i-th line, Ki (0 <= Ki <= N-1), represents the number of rails going out of the i-th intersection. Next Ki numbers represents the intersections directly connected to the i-th intersection.Switch in the i-th intersection is initially pointing in the direction of the first intersection listed.

Output

The first and only line of the output should contain the target minimal number. If there is no route from A to B the line should contain the integer “-1”.

Sample Input

3 2 1

2 2 3

2 3 1

2 1 2

Sample Output

0

Source

Croatia OI 2002 Regional - Juniors

题意:

火车从一点开到另一点,轨道上有很多岔路口,每个路口都有好几个方向(火车能够选任意一个方向开),但是 默认的是 第一个指向的方向,所以如果要选择别的方向的话得 进行一次切换操作 ,给定一个起点一个终点 ,问最少进行几次 切换操作 能够 使 火车 完成这个历程 , 如果开不到,输出“-1”。

分析:

直接将第一个方向的权值设为0,其他方向的权值设为1,然后求起点到终点的最短路即可。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
using namespace std;

const int maxn = 110;
const int INF = 10000000;

struct edge
{
int v,w,next;
}edges[maxn*maxn];

int n,s,ed,e;
int head[maxn],d[maxn];
bool vis[maxn];

void addedges(int u,int v,int w)
{
edges[e].v = v;
edges[e].w = w;
edges[e].next = head[u];
head[u] = e++;
}

void spfa()
{
memset(vis,0,sizeof(vis));
for(int i=1;i<=n;i++) d[i] = INF;
queue<int> q;
d[s] = 0;
q.push(s);
vis[s] = 1;
while(!q.empty())
{
int u = q.front(); q.pop();
vis[u] = 0;
for(int i=head[u];i!=-1;i=edges[i].next)
{
int v = edges[i].v;
int w = edges[i].w;
if(d[v] > d[u] + w)
{
d[v] = d[u] + w;
if(!vis[v])
{
q.push(v);
vis[v] = 1;
}
}
}
}
}

int main()
{
int k,v;
while(scanf("%d%d%d",&n,&s,&ed)!=EOF)
{
e = 0;
memset(head,-1,sizeof(head));
for(int i=1;i<=n;i++)
{
scanf("%d",&k);
for(int j=0;j<k;j++)
{
scanf("%d",&v);
if(j == 0) addedges(i,v,0);
else addedges(i,v,1);
}
}
spfa();
if(d[ed] < INF) printf("%d\n",d[ed]);
else printf("-1\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: