您的位置:首页 > 其它

L - Calm Down(数学几何计算)

2017-10-05 16:57 876 查看
George B. wants to be more than just a good American. He wants to make his daddy proud and become a hero. You know, like Shakib Khan.

But sneaky as he is, he wants a special revolver that will allow him to shoot more often than just the usual six times. This way he can fool and kill the enemy easily (at least that's what he thinks, and that's the best he can think). George has kidnapped
. . . uh, I mean . . . "invited" you and will only let you go if you help him with the math. The piece of the revolver that contains the bullets looks like this (examples for 6 and 17 bullets):



There is a large circle with radius R and n little circles each having radius
r, are placed inside on the border of the large circle. George wants his bullets to be as large as possible, so there should be no space between the circles. George will decide how large the whole revolver will be and how many bullets it shall
contain. Your job is, given R and n, to compute
r. You have decided to help, because you know that an idiot can't make a revolver even if you help him with the math.

Input
Input starts with an integer T (≤ 125), denoting the number of test cases.

Each case contains a real number R (0 < R < 1000 and contains up to at most two places after the decimal point) and an integer
n (2 ≤ n ≤ 100).

Output
For each test case, print the case number and r in a single line. Errors less than
10-6 will be ignored.

Sample Input
4

4.0 6

4.0 17

3.14 100

42 2

Sample Output
Case 1: 1.3333333333

Case 2: 0.6209067545

Case 3: 0.0956260953

Case 4: 21

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;
#define PI acos(-1.0)
int main()
{
double R,r,n;
int t;
double du;
scanf("%d",&t);
for(int o=1;o<=t;o++)
{
scanf("%lf %lf",&R,&n);
n=n*2;
du=PI*2/n;//求出度 然后求余弦
r=R*sin(du)/(1+sin(du));
printf("Case %d: %.10f\n",o,r) ;
}
return 0;
}

emmmmmm注意的就是

以后PI要这么定义 嗯嗯恩恩恩恩记住
#define PI acos(-1.0)
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: