您的位置:首页 > 其它

HDU-4267-A Simple Problem with Integers-(树状数组)

2017-10-05 16:54 573 查看
Problem Description

Let A1, A2, ... , AN be N elements. You need to deal with two kinds of operations. One type of operation is to add a given number to a few numbers in a given interval. The other is to query the value of some element.

 

Input

There are a lot of test cases. The first line contains an integer N. (1 <= N <= 50000) The second line contains N numbers which are the initial values of A1, A2, ... , AN. (-10,000,000 <= the initial value of Ai <= 10,000,000) The third line contains an integer
Q. (1 <= Q <= 50000) Each of the following Q lines represents an operation. "1 a b k c" means adding c to each of Ai which satisfies a <= i <= b and (i - a) % k == 0. (1 <= a <= b <= N, 1 <= k <= 10, -1,000 <= c <= 1,000) "2 a" means querying the value of
Aa. (1 <= a <= N)

 

Output

For each test case, output several lines to answer all query operations.

 

Sample Input

4
1 1 1
4000
1
14
2 1
2 2
2 3
2 4
1 2 3 1 2
2 1
2 2
2 3
2 4
1 1 4 2 1
2 1
2 2
2 3
2 4

 

Sample Output

1
1
1
1
1
3
3
1
2
3
4
1

树状数组很有趣的一种做法

代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<iomanip>
#include<queue>
#include<cstring>
#include<map>
using namespace std;
typedef long long ll;
#define M 50005
int tree[M][11][11];
int p[M];
int n;
inline int lowbit(int i)
{
return i&(-i);
}
void update(int x,int k,int mod,int v)
{
while(x<=n)
{
tree[x][k][mod]+=v;
x+=lowbit(x);
}
}
int query(int x,int y)
{
int ret=0,i;
while(x>0)
{
for(i=1;i<=10;i++)
{
ret+=tree[x][i][y%i];
}
x-=lowbit(x);
}
return ret;
}
int main()
{
int q,i,op,a,b,k,c;
while(scanf("%d",&n)!=EOF)
{
for(i=1;i<=n;i++)
scanf("%d",&p[i]);
memset(tree,0,sizeof(tree));
scanf("%d",&q);
while(q--)
{

scanf("%d",&op);
if(op==2)
{
scanf("%d",&a);
int ans=query(a,a);
printf("%d\n",p[a]+ans);
}
else
{
scanf("%d%d%d%d",&a,&b,&k,&c);
update(a,k,a%k,c);
update(b+1,k,a%k,-c);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: