您的位置:首页 > 其它

链表B 逆序建立链表

2017-10-02 21:03 155 查看
Problem Description

输入整数个数N,再输入N个整数,按照这些整数输入的相反顺序建立单链表,并依次遍历输出单链表的数据。

Input

第一行输入整数N;;

第二行依次输入N个整数,逆序建立单链表。

Output

依次输出单链表所存放的数据。

Example Input

10

11 3 5 27 9 12 43 16 84 22

Example Output

22 84 16 43 12 9 27 5 3 11

Hint

不能使用数组!

#include <stdio.h>
#include <stdlib.h>
struct node
{
int data;
struct node *next;
};
int main()
{
struct node *head,*p;
head = (struct node * )malloc(sizeof(struct node));
head->next = NULL;

int i,n;
scanf("%d",&n);

for(i=0;i<n;i++)
{
p = (struct node * )malloc(sizeof(struct node));
scanf("%d",&p->data);
p->next = head->next;   //第一个插入的为最后一个节点
head->next = p;
}

p = head->next;
printf("%d",p->data);
p = p->next;
for(i=1;i<n;i++)
{
printf(" %d",p->data);
p = p->next;
}
printf("\n");

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: