您的位置:首页 > 其它

hdu1905(判断质数+快速幂)

2017-10-02 19:48 190 查看


Pseudoprime numbers

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3192    Accepted Submission(s): 1441


Problem Description

Fermat's theorem states that for any prime number p and for any integer a > 1, a^p == a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-a pseudoprimes, have
this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.) 

Given 2 < p ≤ 1,000,000,000 and 1 < a < p, determine whether or not p is a base-a pseudoprime. 

 

Input

Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.

 

Output

For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no". 

 

Sample Input

3 2
10 3
341 2
341 3
1105 2
1105 3
0 0

 

Sample Output

no
no
yes
no
yes
yes

 

Author

Gordon V. Cormack

#include<stdio.h>
#include<iostream>
#include<math.h>
using namespace std;
typedef long long ll;
//判断是不是素数+快速幂取模
int prime(int x)
{
for(int i=2;i*i<x;i++)
{
if(x%i==0)
return 0;
}
return 1;
}
ll fsm(ll a,ll b,ll mod)
{
ll res=1;
while(b)
{
if(b&1) res=res*a%mod;
a=a*a%mod;
b>>=1;
}
return res%mod;
}
int main()
{
int p,a;
while(scanf("%d%d",&p,&a)!=EOF)
{
if(!p&&!a)
break;
if(prime(p))
printf("no\n");
else
{
if(fsm(a,p,p)==a)
{
printf("yes\n");
}
else printf("no\n");
}
}
return 0;
}


 

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: