您的位置:首页 > 其它

UVA 439 Knight Moves

2017-10-02 17:40 411 查看
A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to nd the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most di cult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, nding the tour would be easy.

Of course you know that it is vice versa. So you o er him to write a program that solves the ”di cult” part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

Input

The input le will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a..h) representing the column and a digit (1..8) representing the row on the chessboard.

Output

For each test case, print one line saying ‘To get from xx to yy takes n knight moves.’.

Sample Input

e2 e4

a1 b2

b2 c3

a1 h8

a1 h7

h8 a1

b1 c3

f6 f6

Sample Output

To get from e2 to e4 takes 2 knight moves.

To get from a1 to b2 takes 4 knight moves.

To get from b2 to c3 takes 2 knight moves.

To get from a1 to h8 takes 6 knight moves.

To get from a1 to h7 takes 5 knight moves.

To get from h8 to a1 takes 6 knight moves.

To get from b1 to c3 takes 1 knight moves.

To get from f6 to f6 takes 0 knight moves.

题意:

国际象棋中马只能走‘日’字,给出棋盘中的两个位置,输出从第一个位置走到第二个位置所需的步数

思路:

声明一个记录马的坐标的结构体,从起点开始bfs搜索,用数组记录到达每个位置所需的步数,若该位置与终点相同则退出循环

#include <iostream>
#include <queue>
#include <cstring>
using namespace std;
int chessboard[9][9];//棋盘
int dx[]={2,2,1,1,-1,-1,-2,-2};//记录8个位置
int dy[]={1,-1,2,-2,2,-2,1,-1};
struct Knight//结构体,记录当前马的位置
{
int x,y;
};
queue<Knight> q;
int bfs(int x0,int y0)
{
//cout<<x0<<y0<<endl;
Knight k,nk;
while(!q.empty())//队列不为空
{
k=q.front();
q.pop();
if(k.x==x0&&k.y==y0)//若到达终点,退出
break;
else
{
for(int i=0;i<8;i++)//循环8个位置
{
nk.x=k.x+dx[i];
nk.y=k.y+dy[i];
if(nk.x>=1&&nk.x<9&&nk.y>=1&&nk.y<9&&chessboard[nk.x][nk.y]==0)
{
chessboard[nk.x][nk.y] = chessboard[k.x][k.y] + 1;//棋盘记录到达该点所需的步数
q.push(nk);
}
}
}
}
return chessboard[k.x][k.y];

}
int main()
{
Knight k1,k2;
char strb,stre;
int begin,end,steps;
while(cin>>strb>>begin>>stre>>end)
{
steps=0;
while(!q.empty())
q.pop();
memset(chessboard,0,sizeof(chessboard));
k1.x=begin;
k1.y=strb-'a'+1;//转化为整数
k2.x=end;
k2.y=stre-'a'+1;
q.push(k1);//起点添加到队列中
steps=bfs(k2.x,k2.y);
cout<<"To get from "<<strb<<begin<<" to "<<stre<<end<<" takes "<<steps<<" knight moves."<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: