您的位置:首页 > 其它

BZOJ1620: [Usaco2008 Nov]Time Management 时间管理

2017-10-01 22:13 471 查看

Description

Ever the maturing businessman, Farmer John realizes that he must manage his time effectively. He has N jobs conveniently numbered 1..N (1 <= N <= 1,000) to accomplish (like milking the cows, cleaning the barn, mending the fences, and so on). To manage his time effectively, he has created a list of the jobs that must be finished. Job i requires a certain amount of time T_i (1 <= T_i <= 1,000) to complete and furthermore must be finished by time S_i (1 <= S_i <= 1,000,000). Farmer John starts his day at time t=0 and can only work on one job at a time until it is finished. Even a maturing businessman likes to sleep late; help Farmer John determine the latest he can start working and still finish all the jobs on time.

N个工作,每个工作其所需时间,及完成的Deadline,问要完成所有工作,最迟要什么时候开始.

Input

Line 1: A single integer: N

Lines 2..N+1: Line i+1 contains two space-separated integers: T_i and S_i

Output

Line 1: The latest time Farmer John can start working or -1 if Farmer John cannot finish all the jobs on time.

Sample Input

4

3 5

8 14

5 20

1 16

INPUT DETAILS:

Farmer John has 4 jobs to do, which take 3, 8, 5, and 1 units of

time, respectively, and must be completed by time 5, 14, 20, and

16, respectively.

Sample Output

2

OUTPUT DETAILS:

Farmer John must start the first job at time 2. Then he can do

the second, fourth, and third jobs in that order to finish on time.

code

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;

int n;
int start;

struct node{
int tm,ed;
};
node edge[1005];

bool cmp(node a,node b)
{
return a.ed>b.ed;
}

int main()
{
scanf("%d",&n);
for(int i=1;i<=n;i++)
{
scanf("%d%d",&edge[i].tm,&edge[i].ed);
start=max(start,edge[i].ed);
}
sort(edge+1,edge+n+1,cmp);
for(int i=1;i<=n;i++)
{
if(start>edge[i].ed)
start=edge[i].ed;
start-=edge[i].tm;
if(start<0)
{
printf("-1");
exit(0);
}
}
printf("%d",start);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: