您的位置:首页 > 其它

poj 1753 : Flip Game (枚举+dfs)

2017-10-01 20:26 609 查看
Flip Game
Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces,
thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
Choose any one of the 16 pieces. 

Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).


Consider the following position as an example: 

bwbw 

wwww 

bbwb 

bwwb 

Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 

bwww 

wwwb 

wwwb 

The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.
Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible"
(without quotes).
Sample Input
bwwb
bbwb
bwwb
bwww

Sample Output
4
#include<iostream>
using namespace std;

bool map[6][6];
bool Find = false;//最好不要用find,与find()重名
int step;
int dr[5] = { -1,0,0,0,1 };
int dc[5] = { 0,-1,0,1,0 };

bool issame() {		//判断整个棋盘是否是同一颜色
for (int i = 1; i <= 4; i++)
for (int j = 1; j <= 4; j++)
if (map[i][j] != map[1][1])
return false;
return true;
}

void flip(int row, int col) {  //翻转
for (int i = 0; i < 5; i++)
{
int r = row + dr[i];
int c = col + dc[i];
map[r][c] = !map[r][c];
}
}
void dfs(int row, int col, int dep) {
if (dep == step)
{
Find = issame();
return;
}
if (Find || row == 5) return;
flip(row, col); //翻转这个点及其上下左右
if (col < 4) dfs(row, col + 1, dep + 1);
else dfs(row + 1, 1, dep+1);

flip(row, col);   //取消翻转,翻转下一个
if (col < 4) dfs(row, col + 1, dep);
else dfs(row + 1, 1, dep);
}

int main()
{
//freopen("Text.txt", "r", stdin);
char c;
for (int i = 1; i <= 4; i++)
for (int j = 1; j <= 4; j++)
{
cin >> c;
if (c == 'b') map[i][j] = true;
else
{
map[i][j] = false;
}
}
for (step = 0; step <= 16; step++)//分别以16个位置为第一个点开始枚举
{
dfs(1, 1, 0);
if(Find) break;
}
if(Find) cout << step << endl;
else
{
cout << "Impossible" << endl;
}
return 0;
}
转载地址:http://blog.sina.com.cn/s/blog_6635898a0100ivzv.html
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: