您的位置:首页 > 其它

01背包记录路径)

2017-10-01 17:36 232 查看


题目信息

1068. Find More Coins (30)

时间限制150 ms 

内存限制65536 kB 

代码长度限制16000 B

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each
bill, she must pay the exact amount. Since she has as many as 104 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=10^4, the total number of coins) and M(<=10^2, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive
numbers. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the face values V1 <= V2 <= … <= Vk such that V1 + V2 + … + Vk = M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest
sequence. If there is no solution, output “No Solution” instead.

Note: sequence {A[1], A[2], …} is said to be “smaller” than sequence {B[1], B[2], …} if there exists k >= 1 such that A[i]=B[i] for all i < k, and A[k] < B[k].

Sample Input 1: 

8 9 

5 9 8 7 2 3 4 1 
Sample Output 1: 

1 3 5 
Sample Input 2: 

4 8 

7 2 4 3 
Sample Output 2: 

No Solution

#include<iostream>
#include<algorithm>
#include<cstring>
#include<vector>
#define LL long long
#define INF 0x3f3f3f3f

using namespace std;
const int maxn=10005;
const int maxv=105;
int coins[maxn];
int dp[maxv];
bool flag[maxn][maxv];//表示背包容量为j时,是否含有第i个物品
int ans[maxn];
int cnt=0;
bool cmp(int a,int b)
{
return a>b;
}
int main()
{
int n,m;
scanf("%d %d",&n,&m);
for(int i=0;i<n;i++)
scanf("%d",&coins[i]);
sort(coins,coins+n,cmp);//按从大到小排序,即背包里先放大的,再放小的
for(int i=0;i<n;i++)
{
for(int j=m;j>=coins[i];j--)
{
if(dp[j]<=dp[j-coins[i]]+coins[i])
{
dp[j]=dp[j-coins[i]]+coins[i];
flag[i][j]=true;
}
}
}
if(dp[m]!=m)
printf("No Solution");
else
{
int v=m,idx=n-1;
while(v)
{
if(flag[idx][v])
{
ans[cnt++]=coins[idx];
v-=coins[idx];
}
idx--;
}
printf("%d",ans[0]);
for(int i=1;i<cnt;i++)
printf(" %d",ans[i]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: