您的位置:首页 > 其它

PAT 甲级 1058. A+B in Hogwarts (20)

2017-10-01 16:51 525 查看
If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to
compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.
Sample Input:
3.2.1 10.16.27

Sample Output:
14.1.28

#include <iostream>
#include <vector>
#include <algorithm>
#include <cstring>
#include <stack>
#include <queue>
#define lowbit(i) ((i)&(-i))
using namespace std;

int main() {
int g1, g2, s1, s2, k1, k2,g,s,k;
scanf("%d.%d.%d %d.%d.%d", &g1, &s1, &k1, &g2, &s2, &k2);
int carry = 0;
k = (k1 + k2) % 29;
if (k1 + k2 >= 29)
carry = 1;
s = (s1 + s2 + carry) % 17;
if (s1 + s2 + carry >= 17)
carry = 1;
else
carry = 0;
g = g1 + g2 + carry;
printf("%d.%d.%d\n", g, s, k);
cin >> g;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: