您的位置:首页 > 其它

HDU 5979 Convex (几何)

2017-09-28 19:23 295 查看


Convex

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 1080    Accepted Submission(s): 702


Problem Description

We have a special convex that all points have the same distance to origin point.

As you know we can get N segments after linking the origin point and the points on the convex. We can also get N angles between each pair of the neighbor segments.

Now give you the data about the angle, please calculate the area of the convex

 

Input

There are multiple test cases.

The first line contains two integer N and D indicating the number of the points and their distance to origin. (3 <= N <= 10, 1 <= D <= 10)

The next lines contain N integers indicating the angles. The sum of the N numbers is always 360.

 

Output

For each test case output one float numbers indicating the area of the convex. The printed values should have 3 digits after the decimal point.

 

Sample Input

4 1
90 90 90 90
6 1
60 60 60 60 60 60

 

Sample Output

2.000
2.598

 

Source

2016ACM/ICPC亚洲区大连站-重现赛(感谢大连海事大学) 

 

题意:
给你三角形的两边长,和他们的夹角,让你求三角形面积和。

#include <iostream>
#include <stdio.h>
#include <math.h>
using namespace std;
const double PI = acos(-1.0);
int main()
{
int n,d;
while(~scanf("%d %d",&n,&d)){
double ans=0;
for(int i=1;i<=n;i++){
double a;scanf("%lf",&a);
ans+=1.0/2.0*sin(a/180*PI)*1.0*d*d;
}
printf("%.3lf\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: