您的位置:首页 > 其它

The Triangle(POJ-1163)

2017-09-27 20:18 429 查看
               The Triangle

       Time Limit: 1000MS   Memory Limit: 10000K

      Total Submissions: 51473     Accepted: 31121

Description

           7

         3   8

       8   1   0

     2   7   4   4

   4   5   2   6   5

(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5

7

3 8

8 1 0

2 7 4 4

4 5 2 6 5

Sample Output

30

Source

IOI 1994

题目的POJ链接:http://poj.org/problem?id=1163

这是我第一个完全自主做出来DP题,虽然这道题挺水的,但我还是挺开心哒~

题意:求一条权值最大的路径,要求从三角形顶部开始,每步可以向左下或右下走,直到三角形的底部

DP的话,可以从上到下也可以从下到上,状态转移方程为:

  dp[i][j] = max ( dp[i-1][j] + dp[i][j], dp[i-1][j-1] + dp[i][j] ) ;

AC的代码

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
#define N 110
int dp

;
int my_max(int, int);
int main(void)
{
int i,j,k,n;
scanf("%d",&n);
memset(dp, 0, sizeof(dp));
for(i = 1; i <= n; i++)
for(j = 1; j <= i; j++)
scanf("%d",&dp[i][j]);
for(i = 1; i <= n; i++)
for(j = 1; j <=i; j++)
dp[i][j] = my_max(dp[i-1][j]+dp[i][j], dp[i-1][j-1]+dp[i][j]);
k = 0;
for(i = 0; i <= n; i++)
if(dp
[i] > k)
k = dp
[i];
printf("%d\n", k);
return 0;
}
int my_max(int a, int b)
{
return a>b?a:b;
}


更新

若从下向上DP会更简练一些,状态转移方程为:

  dp[i][j] += max(dp[i+1][j], dp[i+1][j+1]);

  

AC的代码

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <string>
#include <cstring>
#include <algorithm>
#include <vector>
#include <stack>
#include <queue>
using namespace std;
#define N 110
int dp

;
int max(int,int);
int main(void)
{
int i,j,k,n;
scanf("%d",&n);
for(i = 1; i <= n; i++)
for(j = 1; j <= i; j++)
scanf("%d",&dp[i][j]);
for(i = n-1; i >=1; i--)
for(j = i; j >=1; j--)
dp[i][j] += max(dp[i+1][j], dp[i+1][j+1]);
printf("%d\n", dp[1][1]);
return 0;
}
int max(int a, int b)
{
return a>b?a:b;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  算法 动态规划