您的位置:首页 > 其它

SGU 115. Calendar (基姆拉尔森公式)

2017-09-27 12:37 363 查看
irst year of new millenium is gone away. In commemoration of it write a program that finds the name of the day of the week for any date in 2001.

Input

Input is a line with two positive integer numbers N and M, where N is a day number in month M. N and M is not more than 100.

Output

Write current number of the day of the week for given date (Monday – number 1, … , Sunday – number 7) or phrase “Impossible” if such date does not exist.

Sample Input

21 10


Sample Output

7


用基姆拉尔森公式算出某年某月某日是星期几。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>

using namespace std;

int CalculateWeekDay(int y, int m,int d)
{
if(m==1||m==2)
m+=12,y--;
int iWeek = (d+2*m+3*(m+1)/5+y+y/4-y/100+y/400)%7;
return iWeek + 1;
}

int j[13] = {0,31,28,31,30,31,30,31,31,30,31,30,31};

int main(void)
{
int m,d;
while(scanf("%d%d",&d,&m)==2)
{
if(m > 12 || m < 1)
{
printf("Impossible\n");
continue;
}
if(d > j[m] || d < 1)
{
printf("Impossible\n");
continue;
}
printf("%d\n",CalculateWeekDay(2001,m,d));
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: