您的位置:首页 > 其它

HDOJ2019

2017-09-26 22:57 525 查看
Problem Description

有n(n<=100)个整数,已经按照从小到大顺序排列好,现在另外给一个整数x,请将该数插入到序列中,并使新的序列仍然有序。

Input

输入数据包含多个测试实例,每组数据由两行组成,第一行是n和m,第二行是已经有序的n个数的数列。n和m同时为0标示输入数据的结束,本行不做处理。

Output

对于每个测试实例,输出插入新的元素后的数列。

Sample Input

3 3

1 2 4

0 0

Sample Output

1 2 3 4

import java.util.Scanner;

class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
while(sc.hasNext()){
int n = sc.nextInt();
int x = sc.nextInt();
if(n==0&&x==0)break;
boolean flag = true;
while(n-->0){
int y = sc.nextInt();
if(x<y&&flag){
System.out.print(x+" "+y);
flag = false;
}else{
System.out.print(y);
}
if(n!=0){
System.out.print(" ");
}
}
System.out.println();
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: