您的位置:首页 > 其它

HDU 2588 GCD (欧拉函数)

2017-09-26 22:10 429 查看


GCD

                                                           Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K
(Java/Others)

                                                           Total Submission(s): 2473    Accepted Submission(s): 1282


Problem Description

The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.

(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:

Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.

 

Input

The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.

 

Output

For each test case,output the answer on a single line.

 

Sample Input

3
1 1
10 2
10000 72

 

Sample Output

1
6
260

大意:给你一个n,m,求有多少个 i 满足gcd(i,n)>=m

思路:对于每个1<=i<=n,有gcd(i,n)>=m,可化为n=a*b,i=a*d,显然,因为gcd所以b,d互质且b>=d,a>=m,即求euler(b),即a从1开始枚举到n,显然

这种做法是超时的,故折半枚举,诺a满足a>=m,则有对应的n/a,诺n/a>=m则这种情况也是满足的,所以只需要枚举sqrt(n)次,注意i*i==n的情况

上代码:

#include<iostream>
#include<cmath>
#include<cstring>
#include<string>
#include<queue>
#include<cstdio>
#include<stack>
#include<vector>
#include<algorithm>
using namespace std;
const int M=10e+10;
#define ll long long
#define inf 0x3f3f3f3f
#define llinf 0x3f3f3f3f3f3f3f3f
int euler(int n)
{
int res=n;
for(int i=2;i*i<=n;i++)
{
if(n%i==0)
{
res=res/i*(i-1);
while(n%i==0)
n/=i;
}
}
if(n>1)
return res=res/n*(n-1);
return res;
}
int main()
{
int t,n,m;
cin>>t;
while(t--)
{
cin>>n>>m;
int ans=0;
for(int i=1;i*i<=n;i++)//m=1的情况可以特判为n
{
if(n%i==0)
{
if(i>=m)
ans+=euler(n/i);
if(n/i>=m&&i*i!=n)//n/i=n的欧拉函数值为1,互质数为n
ans+=euler(i);
}
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  欧拉函数