您的位置:首页 > 其它

HD-1213-How Many Tables(并查集)

2017-09-26 21:38 337 查看
[align=left]Problem Description[/align]Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 
[align=left]Input[/align]The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 
[align=left]Output[/align]For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 
[align=left]Sample Input[/align]
2
5 3
1 2
2 3
4 5

5 1
2 5 
[align=left]Sample Output[/align]
2
4

题意:有人过生日,邀请了很多朋友,而这些朋友并不是每个人都是相互认识的,那么,请你把互相认识的人放在一个桌子上,那这人需要准备多少张桌子?

这是一道并查集的模板题,只需要套用模板就行

代码如下:
#include <cstdio>
int i[1005];
int check(int x)
{
int r = x;
while(r!=i[r])
r = i[r];
return r;
}
void binchaji(int x,int y)
{
int fx,fy;
fx = check(x);
fy = check(y);
if(fx!=fy)
i[fx] = fy;
}
int main()
{
int n;
int p,q;
scanf("%d",&n);
int x,y;
while(n--)
{
scanf("%d%d",&p,&q);
for(int a = 1; a <= p; a ++)
i[a] = a;
for(int a = 0; a < q; a ++)
{
scanf("%d%d",&x,&y);
binchaji(x,y);
}
int num = 0;
for(int a = 1; a <= p; a ++)
{
if(i[a]==a)
num++;
}
printf("%d\n",num);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: