您的位置:首页 > 其它

PAT 甲级 1039. Course List for Student (25)

2017-09-26 15:38 393 查看
Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the
courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni student
names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing
order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.
Sample Input:
11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:
ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

ps:直接用string好像会超时,所以用散列将名字存到数组里。

#include <string>
#include <iostream>
#include <algorithm>
#include <vector>;
using namespace std;
const int maxn = 26 * 26 * 26 * 10 + 10;
vector<int> v[maxn];
int getid(char *name) {
int id = 0;
for (int i = 0; i < 3; i++) {
id = id * 26 + (name[i] - 'A');
}
id = id * 10 + (name[3] - '0');
return id;
}
int main() {
int n, k;
cin >> n >> k;
for (int i = 0; i < k; i++) {
int cid, num;
cin >> cid >> num;
for (int j = 0; j < num; j++) {
char temp[5];
scanf("%s", temp);
int id = getid(temp);
v[id].push_back(cid);
}
}
for (int i = 0; i < n; i++) {
char temp[5];
scanf("%s", temp);
int id = getid(temp);
sort(v[id].begin(), v[id].end());
printf("%s %d", temp,v[id].size());
for (int j = 0; j < v[id].size(); j++)
printf(" %d", v[id][j]);
printf("\n");
}
//cin >> k;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: