您的位置:首页 > 编程语言 > C语言/C++

poj 2653 Pick-up sticks

2017-09-26 08:30 411 查看
Pick-up sticks

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 13844 Accepted: 5249
Description

Stan has n sticks of various length. He throws them one at a time on the floor in a random way. After finishing throwing, Stan tries to find the top sticks, that is these sticks such that there is no stick on top of them. Stan has noticed that the last thrown
stick is always on top but he wants to know all the sticks that are on top. Stan sticks are very, very thin such that their thickness can be neglected.
Input

Input consists of a number of cases. The data for each case start with 1 <= n <= 100000, the number of sticks for this case. The following n lines contain four numbers each, these numbers are the planar coordinates of the endpoints of one stick. The sticks
are listed in the order in which Stan has thrown them. You may assume that there are no more than 1000 top sticks. The input is ended by the case with n=0. This case should not be processed.
Output

For each input case, print one line of output listing the top sticks in the format given in the sample. The top sticks should be listed in order in which they were thrown. 

The picture to the right below illustrates the first case from input.


Sample Input
5
1 1 4 2
2 3 3 1
1 -2.0 8 4
1 4 8 2
3 3 6 -2.0
3
0 0 1 1
1 0 2 1
2 0 3 1
0

Sample Output
Top sticks: 2, 4, 5.
Top sticks: 1, 2, 3.

Hint

Huge input,scanf is recommended.

分析:今天又学了一招,还是上次的向量表达式,判断是否相交;上次是判断直线与线段,这次是线段与线段,线段相交,一条线段的两端点,在另一条线段所在直线的两侧,反过来也是,必须同时满足。

代码如下:

#include<iostream>
#include<cstdio>

struct Node {
double x1,x2,y1,y2;
}data[100005];
int ans[100005];
int n;

double calc(double x1,double y1,double x2,double y2,double x3,double y3)
{
return ((x3-x1)*(y2-y1))-((x2-x1)*(y3-y1));
}
int judge(int x)
{
if(x==n-1)
return 1;
for(int i=x+1;i<n;i++)
{//互相在对方的两侧
double tem1=calc(data[x].x1,data[x].y1,data[x].x2,data[x].y2,data[i].x1,data[i].y1);
double tem2=calc(data[x].x1,data[x].y1,data[x].x2,data[x].y2,data[i].x2,data[i].y2);
double tem3=calc(data[i].x1,data[i].y1,data[i].x2,data[i].y2,data[x].x1,data[x].y1);
double tem4=calc(data[i].x1,data[i].y1,data[i].x2,data[i].y2,data[x].x2,data[x].y2);
if(tem1*tem2<=0 && tem3*tem4<=0)
return 0;
}
return 1;
}

int main()
{
int inde;
while(scanf("%d",&n),n)
{
inde=0;
for(int i=0;i<n;i++)
scanf("%lf%lf%lf%lf",&data[i].x1,&data[i].y1,&data[i].x2,&data[i].y2);

for(int i=0;i<n;i++)
{
if(judge(i))
ans[inde++]=i;
}
printf("Top sticks:");
for(int i=0;i<inde-1;i++)
printf(" %d,",ans[i]+1);
printf(" %d.\n",ans[inde-1]+1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息