您的位置:首页 > 其它

(HDU - 1698)Just a Hook

2017-09-25 20:36 399 查看

(HDU - 1698)Just a Hook

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 35578 Accepted Submission(s): 17370

Problem Description

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.

The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.

For each silver stick, the value is 2.

For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.

You may consider the original hook is made up of cupreous sticks.

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.

For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.

Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

Output

For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

Sample Input

1

10

2

1 5 2

5 9 3

Sample Output

Case 1: The total value of the hook is 24.

题目大意:data里面有个英雄有一个肉钩,这个肉钩有n节,开始这n节全是铜的,现在进行q次操作每一次将区间[l,r]的钩子变成铜,银,或金。其中铜的权值算1,银算2,金算3。问操作完之后这些钩子加起来权值的和是多少。

思路:线段树维护这1到n的区间,区间更新与区间查询。

#include<cstdio>
#define ls o<<1
#define lr o<<1|1
using namespace std;

const int maxn=100005;

struct node
{
int l,r,len;
int sum,lazy;
}T[maxn<<2];

void pushup(int o)
{
T[o].sum=T[ls].sum+T[lr].sum;
}

void build(int o,int l, int r)
{
T[o].l=l;
T[o].r=r;
T[o].len=r-l+1;
T[o].lazy=0;
if(l==r)
{
T[o].sum=1;
return;
}
int mid=(l+r)>>1;
build(ls,l,mid);
build(lr,mid+1,r);
pushup(o);
}

void pushdown(int o)
{
T[ls].lazy=T[o].lazy;
T[lr].lazy=T[o].lazy;
T[ls].sum=T[o].lazy*T[ls].len;
T[lr].sum=T[o].lazy*T[lr].len;
T[o].lazy=0;
}

void update(int o,int l,int r,int lazy)
{
if(T[o].l==l&&T[o].r==r)
{
T[o].lazy=lazy;
T[o].sum=lazy*T[o].len;
return;
}
if(T[o].lazy) pushdown(o);
int mid=(T[o].l+T[o].r)>>1;
if(mid>=r) update(ls,l,r,lazy);
else if(mid<l) update(lr,l,r,lazy);
else
{
update(ls,l,mid,lazy);
update(lr,mid+1,r,lazy);
}
pushup(o);
}

int query(int o,int l,int r)
{
if(T[o].l==T[o].r) return T[o].sum;
if(T[o].lazy) pushdown(o);
int mid=(T[o].l+T[o].r)>>1;
if(mid>=r) return query(ls,l,r);
else if(mid<l) return query(lr,l,r);
else return query(ls,l,mid)+query(lr,mid+1,r);
}

int main()
{
int t,kase=0;
scanf("%d",&t);
while(t--)
{
int n,q;
scanf("%d%d",&n,&q);
build(1,1,n);
while(q--)
{
int x,y,z;
scanf("%d%d%d",&x,&y,&z);
update(1,x,y,z);
}
printf("Case %d: The total value of the hook is %d.\n",++kase,query(1,1,n));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: