您的位置:首页 > 其它

HDU 1013 Digital Roots

2017-09-25 16:45 435 查看


Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 81141    Accepted Submission(s): 25390


Problem Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is
repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process
must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

 

Input

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

 

Output

For each integer in the input, output its digital root on a separate line of the output.

 

Sample Input

24
39
0

 

Sample Output

6
3

 
题目大意:给你一个数,如果这个数的每一位数字加起来以后是一个个位数,就输出这个个位数,否则就一直重复,直到它的每一位数字加起来的和是个个位数
要用字符串来写......

#include<iostream>
#include<string>
#include<vector>
using namespace std;
typedef long long ll;
int main(){
string str;
while(cin>>str){
if(str[0]=='0'&&str.length()==1) break;
if(str.length()==1) cout<<str<<endl;
else{
while(1){
int a=0;
for(int i=0;i<str.length();i++){
a+=str[i]-'0';
}
if(a/10==0){
cout<<a<<endl;
break;
}
else{
str.clear();
do{
str.push_back(a%10+'0');
a/=10;
}while(a);
}
}
}
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: