您的位置:首页 > 大数据 > 人工智能

Easier Done Than Said?(字符串)

2017-09-24 20:18 176 查看
Easier Done Than Said?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 14164 Accepted Submission(s): 6867

Problem Description

Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering them and sometimes leave them written on notes stuck to their computer. One potential solution is to generate “pronounceable” passwords that are relatively secure but still easy to remember.

FnordCom is developing such a password generator. You work in the quality control department, and it’s your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:

It must contain at least one vowel.

It cannot contain three consecutive vowels or three consecutive consonants.

It cannot contain two consecutive occurrences of the same letter, except for ‘ee’ or ‘oo’.

(For the purposes of this problem, the vowels are ‘a’, ‘e’, ‘i’, ‘o’, and ‘u’; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.

Input

The input consists of one or more potential passwords, one per line, followed by a line containing only the word ‘end’ that signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters.

Output

For each password, output whether or not it is acceptable, using the precise format shown in the example.

Sample Input

a

tv

ptoui

bontres

zoggax

wiinq

eep

houctuh

end

Sample Output

is acceptable.

is not acceptable.

is not acceptable.

is not acceptable.

is not acceptable.

is not acceptable.

is acceptable.

is acceptable.

#include<stdio.h>
#include<string.h>
char aa[1000000];
int one(char str[])
{
for(int i =0;i<strlen(str);i++)
{
if(str[i]=='a'||str[i]=='e'||str[i]=='i'||str[i]=='o'||str[i]=='u')
return 1;
}
return 0;
}
int two(char str[])
{
int num =0;
for(int i =0;i<strlen(str);i++)
{
if(str[i]=='a'||str[i]=='e'||str[i]=='i'||str[i]=='o'||str[i]=='u')
num++;
else
num =0;
if(num == 3) return 0;
}
return 1;
}
int three(char str[])
{
int num =0;
for(int i =0;i<strlen(str);i++)
{
if(str[i]!='a'&&str[i]!='e'&&str[i]!='i'&&str[i]!='o'&&str[i]!='u')
num++;
else
num =0;
if(num == 3) return 0;
}
return 1;
}
int four(char str[])
{
char pre = str[0];
int num =1;
for(int i = 1;i<strlen(str);i++)
{
if(pre == str[i]&&pre!='e'&&pre!='o')
return 0;
else if(pre!=str[i])
pre = str[i];
}
return 1;
}
int main()
{

while(~scanf("%s",aa))
{
if(strcmp(aa,"end")==0) break;
if(one(aa)&&two(aa)&&three(aa)&&four(aa))
printf("<%s> is acceptable.\n",aa);
else
printf("<%s> is not acceptable.\n",aa);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  水题