您的位置:首页 > 其它

Matrix 二维树状数组 区间修改+单点查询

2017-09-24 16:22 423 查看
Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change
it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).

2. Q x y (1 <= x, y <= n) querys A[x, y].

Input
The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2
y2", which has been described above.

Output
For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input
1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output
1
0
0
1


鸡冻,模仿着一维树状数组敲出来提交一发AC。这道题挺有意思,修改一个矩阵区间,区间内的数一开始都为0,修改的时候0变为1,1变为0,询问一个点看它是0还是为1

每次修改让每个数加一,最后看它的奇偶性就行了,其实不难qwq

#include <iostream>
#include <cstdio>
#include <cstring>
#define lowbit(x) (x & (-x))

using namespace std;
const int N = 1e3 + 3;

int c

;

void Update(int x, int y, int v)
{
for(int i = x; i > 0; i -= lowbit(i))
for(int j = y; j > 0; j -= lowbit(j))
c[i][j] += v;
}
int GetSum(int x, int y)
{
int sum = 0;
for(int i = x; i < N; i += lowbit(i))
for(int j = y; j < N; j += lowbit(j))
sum += c[i][j];
return sum;
}
int main()
{
int x, n, t, x1, y1, x2, y2;
char s[2];
scanf("%d", &x);
for(int k = 1; k <= x; k++)
{
memset(c, 0, sizeof(c));
scanf("%d%d", &n, &t);
while(t--)
{
scanf("%s", s);
if(s[0] == 'C')
{
scanf("%d%d%d%d", &x1, &y1, &x2, &y2);
Update(x2, y2, 1);
Update(x1 - 1, y2, -1);
Update(x2, y1 - 1, -1);
Update(x1 - 1, y1 - 1, 1);
}
else
{
scanf("%d%d", &x1, &y1);
if(GetSum(x1, y1) % 2 == 1)
printf("1\n");
else
printf("0\n");
}
}
if(k < x)
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: