您的位置:首页 > 产品设计 > UI/UE

[PAT]1017. Queueing at Bank (25)@Java

2017-09-22 11:45 519 查看


1017. Queueing at Bank (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a
window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10000) - the total number of customers, and K (<=100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the
processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.
Sample Input:
7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10

Sample Output:
8.2


该解法参考某C++算法,但是在PAT有一个点无法AC,

package go.jacob.day922;

import java.util.ArrayList;
import java.util.Collections;
import java.util.Comparator;
import java.util.Scanner;

public class Demo2 {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int N = sc.nextInt(), K = sc.nextInt();
ArrayList<Customer> list = new ArrayList<Customer>();
int[] windows = new int[K];
// 记录等待时间
int waitTime = 0;
// 将17:0:0前到达的顾客存入list
for (int i = 0; i < N; i++) {
String time = sc.next();
int needTime = sc.nextInt();
// 说明超时到达
if (time.compareTo("17:00:00") > 0)
continue;
String[] arr = time.split(":");
int h = Integer.parseInt(arr[0]), m = Integer.parseInt(arr[1]), s = Integer.parseInt(arr[2]);
int arriveTime = h * 3600 + m * 60 + s;
if (arriveTime < 8 * 3600) {
waitTime += 8 * 3600 - arriveTime;
}
list.add(new Customer(arriveTime, needTime));
}
// 按到达时间排序
Collections.sort(list, new Comparator<Customer>() {
@Override
public int compare(Customer c1, Customer c2) {
return c1.arriveTime - c2.arriveTime;
}
});
for (int i = 0; i < list.size(); i++) {
Customer c = list.get(i);
int w = findFreeWindow(windows, c);
// 找到空闲窗口
if (w >= 0) {
if (c.arriveTime < 8 * 3600) {
windows[w] = 8 * 3600 + c.needTime;
} else {
windows[w] = c.arriveTime + c.needTime;
}
} else {// 不存在空闲窗口,顾客需要等待
w = findFirstFreeWindow(windows);
//因为之前waitTime已经加上相对8点的等待时间,所以这里必须判断
if (c.arriveTime < 8 * 3600) {
waitTime += windows[w] - 8 * 3600;
windows[w] += c.needTime;
} else {
waitTime += windows[w] - c.arriveTime;
windows[w] += c.needTime;
}
}
}
System.out.printf("%.1f", waitTime / 60.0 / list.size());
sc.close();
}

private static int findFirstFreeWindow(int[] windows) {
int first = 0;
for (int i = 1; i < windows.length; i++) {
if (windows[i] < windows[first])
first = i;
}
return first;
}

// 试图找到当前顾客可以直接进入的窗口
private static int findFreeWindow(int[] windows, Customer customer) {
for (int i = 0; i < windows.length; i++) {
if (windows[i] <= customer.arriveTime)
return i;
}
return -1;
}
}

class Customer {
int arriveTime;
int needTime;

public Customer(int arriveTime, int needTime) {
super();
this.arriveTime = arriveTime;
this.needTime = needTime * 60;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: