您的位置:首页 > 其它

POJ-2386 Lake Counting(dfs)(白书2.1.4)

2017-09-21 17:59 417 查看
Language:

Lake Counting

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 37122 Accepted: 18462

Description

Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (‘.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John’s field, determine how many ponds he has.

Input

Line 1: Two space-separated integers: N and M

Lines 2..N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.

Output

Line 1: The number of ponds in Farmer John’s field.

Sample Input

10 12

W……..WW.

.WWW…..WWW

….WW…WW.

………WW.

………W..

..W……W..

.W.W…..WW.

W.W.W…..W.

.W.W……W.

..W…….W.

Sample Output

3

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX = 110;
char mapp[MAX][MAX];
int xb[8]={-1,0,1,-1,1,-1,0,1};
int yb[8]={1,1,1,0,0,-1,-1,-1};
int num;
int n,m;
void dfs(int x,int y)
{
if(x<0||x>=n||y<0||y>=m||mapp[x][y]=='.')
return ;
mapp[x][y]='.';
for(int i=0;i<8;i++)
{
int xx=x+xb[i];
int yy=y+yb[i];
dfs(xx,yy);
}
}
int main()
{
while(scanf("%d%d",&n,&m)!=EOF)
{
getchar();
num=0;
memset(mapp,0,sizeof(mapp));
for(int i=0;i<n;i++)
{
for(int j=0;j<m;j++)
{
scanf("%c",&mapp[i][j]);
}
getchar();
}
for(int i=0;i<n;i++)
{
for(int j=0;j<m;j++)
{
if(mapp[i][j]=='W')
{
dfs(i,j);
num++;
}
}
}

printf("%d\n",num);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: