您的位置:首页 > Web前端

A Bug's Life HDU - 1829 (并查集)

2017-09-21 17:37 295 查看
Background

Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.

Problem

Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing “Scenario #i:”, where i is the number of the scenario starting at 1, followed by one line saying either “No suspicious bugs found!” if the experiment is consistent with his assumption about the bugs’ sexual behavior, or “Suspicious bugs found!” if Professor Hopper’s assumption is definitely wrong.

Sample Input

2

3 3

1 2

2 3

1 3

4 2

1 2

3 4

Sample Output

Scenario #1:

Suspicious bugs found!

Scenario #2:

No suspicious bugs found!

并查集的一个便是,难度中等

#include<cstdio>
#include<algorithm>
#include<cstring>
#define N 2005
#define INF 0x3f3f3f3f
typedef long long ll;
using namespace std;
int n,m;
int pre
;
int opp
;
int findd(int x)
{
return pre[x]==x?x:pre[x]=findd(pre[x]);
}
void init()
{
for(int i=1;i<=n;i++)
pre[i]=i;
memset(opp,0,sizeof(opp));
}
int main()
{
int t;
int x,y;
int cal=1;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
init();
bool sign=true;
while(m--)
{
scanf("%d%d",&x,&y);
if(sign)
{
if(!opp[x])
{
opp[x]=y;
if(!opp[y])
opp[y]=x;
else
{
int xx=findd(x);
int oo=findd(opp[y]);
if(xx!=oo)
pre[xx]=oo;
}
}
else
{
int yy=findd(y);
int oo=findd(opp[x]);
if(oo!=yy)
pre[yy]=oo;
if(!opp[y])
opp[y]=x;
else
{
int xx=findd(x);
oo=findd(opp[y]);
if(xx!=oo)
pre[xx]=oo;
}
}
int xx=findd(x);
int yy=findd(y);
if(xx==yy)
sign=false;
}
}
printf("Scenario #%d:\n",cal++);
if(sign)
printf("No suspicious bugs found!\n");
else
printf("Suspicious bugs found!\n");
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: