您的位置:首页 > 其它

HDU 2680 Choose the best route

2017-09-20 22:02 85 查看

                                                                     Choose the best route

            Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

                                   Total Submission(s): 15487    Accepted Submission(s): 5024


[align=left]Problem Description[/align]
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the
stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer
1,2,3…n.
 

[align=left]Input[/align]
There are several test cases.

Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands
for the bus station that near Kiki’s friend’s home.

Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .

Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.

 

[align=left]Output[/align]
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

[align=left]Sample Input[/align]

5 8 5
1 2 2
1 5 3
1 3 4
2 4 7
2 5 6
2 3 5
3 5 1
4 5 1
2
2 3
4 3 4
1 2 3
1 3 4
2 3 2
1
1

 

[align=left]Sample Output[/align]

1
-1问题描述:求多个节点到达一个节点的所有路径中的最小路径。解题思路:增加节点,该节点到各起始节点之间的距离置为0,之后运用迪杰斯特拉,求一遍最短路,输出dis数组中下标为终点的值即可。代码: #include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[1010][1010],b[1010],dis[1010];
int main()
{
int i,j,k,t1,t2,t3,m,n,min1,inf,s,x;
inf=99999999;
while(scanf("%d%d%d",&m,&n,&s)!=EOF)
{
for(i=0;i<=m;i++)
 for(j=0;j<=m;j++)
   a[i][j]=inf;
for(i=0;i<n;i++)
{
scanf("%d%d%d",&t1,&t2,&t3);
if(t3<a[t1][t2])
  a[t1][t2]=t3;
}
memset(b,0,sizeof(b));
scanf("%d",&x);
for(i=0;i<x;i++)
{
scanf("%d",&t3);
a[0][t3]=0;
}
for(i=0;i<=m;i++)
 dis[i]=a[0][i];
 b[0]=1;
for(i=1;i<m;i++)
{
min1=inf;
for(j=0;j<=m;j++)
{
if(min1>dis[j] &&!b[j])
  min1=dis[j],k=j;
}
b[k]=1;
for(j=0;j<=m;j++)
{
if(!b[j] && dis[j]>dis[k]+a[k][j])
  dis[j]=dis[k]+a[k][j];
}
}
if(dis[s]==inf)
  printf("-1\n");
else
  printf("%d\n",dis[s]);
}
return 0;
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: